My Ip Address appears as a removable disk

I am not sure how to otherwise explain this, but you know how when you plug some USB stick or something into your computer and it appears as a removable disk.
So occasionally I have an (or mine) IP address appear in that same little triangle. I click on it and it goes away but it keeps coming back.
I did install proton VPN with the OpenVPN thing and I noticed it happening after that.
I also installed prior to using OpenVPN, proton via terminal like mentioned on Protons website, not really knowing what I was doing but it worked until I close the terminal.
I checked leakIp.com or something and I seem to be ok.
Just wondering if I can fix this, thanks.

That sounds almost like a samba share or external drive over a router...

What does that mean please?

It sounds like you are remotely mounting a drive over a network connection.

Is there a way to undo this?

I have no idea how it got done.:wink:

Did it only begin showing this effect after setting up OpenVPN and ProtonVPN?

Yes, but I have been updating things and I feel like that my gnome isn't working correctly, perhaps that can have something to do with it?

It is possible. What you see in File Manager is a result of Nautilus Desktop working with Gnome-Shell.
If you are experiencing many different problems after trying many different things - a Clean Wipe and Reinstall of the OS really is the way to go.
It is never as bad as you fear...

When I first moved to Zorin from Windows... I really tinkered a lot. I was reinstalling Zorin OS once a week. Then... once a month.
Later, it would be many months.
And now, I pretty much never have to reinstall.
On Windows, it is true that I never needed to wipe and reinstall so often. But, I also never progressed at all. On Windows, my system would progressively get worse until finally reinstalling in an endless cycle.

As you build confidence and knowledge of the system on Linux, it really does get much easier.

I would reinstall clean and fresh. And with some mistakes no longer relevant or some trials and efforts no longer needed, apply what you have learned from the last round to set up VPN in a workable way.
I would try that First Thing.
That way, if it goes wrong... it's much easier to fix.
Once that is done, you can modify more things.

1 Like

Oh no, I was hoping to be done with that. Mainly because I had to gather everything for brave again. For some reason the sync isn't working for me. Meaning I have to get the bookmarks manually back but more important my extensions didnt sync.

I am noticing a new problem right now, when I turn my VPN on I am stuck on load. And nothign happens. Any idea why that is. It worked fine last week.

I am far short of being an expert here and it seems you have multiple problems. Are you also using a firewall? Have a wireless adapter enabled while a Ethernet adapter is enabled? Proton VPN uses the same login credentials as your email account. Both should be either one part or two part authentication.

Just in case...did you use this procedure? Look also at the manually configure link.

Proton VPN Instructions

No I am not using a firewall. Just got the open VPN configured with proton and I also have the proton app installed. Maybe they are deleting each other or something.

Take a look at my previous post for the link...I was editing when you replied. :slight_smile:

It shows how to configure PVPN with OVPN.

I am curious, are you using a wireless USB adapter?

Also, look up "disable kill switch" for Proton VPN. As well, I have read some people are having better luck with starting it with the command line (terminal) and then going to the GUI to monitor.

You can also contact ProtonMail and ask them but it may be a canned response as there are numerous Linux distros and they cannot know them all.

1 Like

Well...per the vast knowledge of the web, there are various issues with installs. There are suggestions to uninstall the PVPN and to be certain to remove the ~/.cache/protonvpn. Some say to at least empty the cache. When you did the install, was it by the Software tool or was it manual? Some users when using the CLI have had conflicts with a python version plus needed to install other modules. Did you see any install errors?

1 Like