My keyboard and mouse won't work after starting the PC

Hi!

I am encountering a problem with Zorin 15.3 where, after logging in, both the mouse and keyboard cease to function, rendering me unable to perform any actions.

It's worth noting that the system itself appears to be functioning, as the clock is still operational, and it recognizes USB drives.

However, the input devices become unresponsive upon login, preventing me from interacting with the system.

Computer: laptop Asus X552M; dual-boot with Windows 10 (this OS is working properly).

TIA!

In order to enter in commands, you may need to boot into recovery mode

From the Recovery Menu, arrow key down to Root - Drop to Prompt
tap enter
Then run in terminal:

sudo apt remove xserver-xorg-input-all

Once complete, reboot and test.

Hello Aravisian.

I tried that command. This was the output:

"Package 'xserver-xorg-input-all' is not installed, so not removed"

Zorin OS relies on using libinput.
If libinput is not working once you reach the desktop and the sxerver package is not installed...
Then let's try installing it, instead. :grin:

sudo apt install xserver-xorg-input-all

Boot up and test...

Hey!

I tried to install it. There's the output:

Ah, sorry...
In the recovery menu, first arrow key to Enable Networking
Once that is down, arrow key down to Root - drop to prompt and run the command then.

Unfortunately, the output was similar. The same errors.

Is enabling networking failing?
Maybe connect by Ethernet first, if you have that option available?

Yeah, "Enable networking" is failing.

I can't use an Ethernet cable in this laptop, since that port is not working.
´
I went to dkpg (fix package manager issues) and I saw this output: "No candidate ver: chrome-remote-desktop".

I don't know if that helps. I tried to install Chrome Remote Desktop yesterday (then I proceeded to unistall it). It might be related to this problem, I'm not sure.

Did mouse and keyboard stop working right after that attempt?

Yeah, I guess. After installing Chrome Remote Desktop, it kept working (mouse and keyboard). But when I turned off the laptop and turned it on today it's stopped working

If I might ask, are you still on 15.3 in order to have 32bit architecture?

Before installing 15.3, I had Zorin OS 16 but It had some bugs while installing it, so I decided to install 15.3. It was working nicely until today.

I am a bit stuck given that you need net access in recovery (Where the keyboard is working) or you need the keyboard and/or mouse to work in order to apply the commands in a terminal on the desktop.

When you removed the Chrome remote desktop, do you recall the terminal noting other dependencies that would be removed?

I'm not sure I understanded the first part. My keyboard and mouse work in Recovery Mode, they stop working immediately when desktop shows up.

When I'm in Recovery Mode, I don't have net acess at all? Even with WiFi connected?

I don't recall, since I unistalled it directly in the Software Store.

You are saying that you do not... I can only go by what you relay.

Ah, I see. the Software store is non-verbose. That is why I prefer the terminal or Synaptic Package Manager.
I cannot be sure what was removed that may have affected your system. It seems unlikely to me that the drivers for keyboard and mouse would both go missing without a direct cause.

Every suggestion I can think of involves needing keyboard access and net access.
How do you feel about backing up your personal data and reinstalling Zorin OS Lite?

"How do you feel about backing up your personal data and reinstalling Zorin OS Lite?" Yeah, I feel there's no other way... :frowning:

How can I backup my personal data? Using Zorin OS 15.3 installation (I have it on a usb pen). I just copy it to an external drive or there is another method, a more efficient one?

This is how I do it, as well - because it is the most reliable method I have ever used.

1 Like

You could connect your phone, enable USB tether in connection settings and gain access to the internet that way.

If removing Chrome Remote Desktop took a lot of system libraries out, maybe reinstalling it may return the libraries. Then we can focus on removing Chrome Remote Desktop.

Enabling the firewall and refusing access to Chrome Remote Desktop will keep your system safe until you can get it removed.

2 Likes

Hi guys!

Can I do something to fix it using a Live Bootable Media? I can use Internet while in a Live Bootable Media (zorin 15.3 lite)

Like a command to update and upgrade the selected disk (for instance, sda6)

TIA