My os booted into black screen with a mouse pointer

Today i was working on my pc and suddenly a black screen appeared and told me to press ctrl + alt + f2 and o have Done that. It takes me to the tty terminal, i can't escape the tty terminal so i forced shurtdown my pc and then after o boot it takes me a black screen whit only my mouse pointer. How to solve this bro

Os KDE neon

KDE Neon Boots to Black Screen with Mouse Cursor - Antropy - OpenCart Developers.

1 Like

Thanks but already tried that

Not working

Adarsh, you are, of course, always welcome on the forum. However, for Distro Specific troubleshooting, you may get the best results from visiting that distros helpdesk.

1 Like

Ok i also think so, but i have tried that once, they don't even see my post. Last time they responder after 6 months

Perhaps existing tips may help:

Check if Home Directory is full.
Check if broken pacakges.


Okay thanks i am trying that.

I used sudo apt dist-upgrade and it said i will take 1955 mb of data, i don't have that much data

Are u sure by this command my problem will fix ? Because now i have to buy extra data and it will cost me money.

Thanks @zabadabadoo

I cant help with your problem, but I can correct typo's. :laughing:

1 Like

Hello Adarsh
If you still access the tty
Can you pls share the output of the command?

inxi -P 
1 Like

Yes, okay I am trying that

Sorry, can't answer yesterday, My tty terminal। is not working so I tried that with recovery mode terminal. It's said me to install inxi using apt install inxi

Now I have installed inxi
And। over this result -


ID - 1: / size: 290.45 GIB used: 137.89 GIB (47.5 present) FS: ext4 Dev: /Dev/sda2

ID - 2: swap-1 size: 9.47 GIB used: 0 KIB (0.0 present) FS: swap Dev: /Dev/sda4

Okay, now what I have to do ?

Hello @Aravisian are u sure about this.

If that is what it requires to update- then that is what it requires... I cannot vouch for the limits placed on your data... Perhaps you can find a Better Provider for service.

1 Like

Ohk thanks