My PC crashes my network

A bit of a strange problem. My internet was working fine a few days ago but then it started disconnecting. It works fine on all of my devices until I turn on my PC. Once my PC is on and connected (to either Wifi, or Ethernet) it causes my entire network to crash so nothing is able to connect. As soon as I disconnect the internet from my PC everything starts working again. It is my PC with Zorin 16.

lshw -c network

description: Wireless interface
product: Wi-Fi 6 AX200
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 1a
serial: 60:f2:62:51:0e:05
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.8.0-59-generic firmware=55.d9698065.0 cc-a0-55.ucode ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:29 memory:f6600000-f6603fff
description: Ethernet interface
product: RTL8125 2.5GbE Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:04:00.0
logical name: enp4s0
version: 04
serial: 3c:7c:3f:d7:76:83
size: 1Gbit/s
capacity: 2500Mbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd 2500bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8125 driverversion=9.005.06-NAPI duplex=full latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:34 ioport:f000(size=256) memory:f6500000-f650ffff memory:f6510000-f6513fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

When was the last time you restarted your router? Is access control on or configured? Did this start happening recently? Did this always occur in zorin 16 or have you installed hardware or drivers recently before the occurrences started?

Everything from the terminal looks good...i doubt it's a driver issue.... but i haven't experienced adapters with wifi 6 capability yet. Is the adapter configurable to automatically or manually connect to wifi 6 networks? If so can you try shutting that option off? Wifi 6 shouldn't isolate the network, that's the router's job. It's the router wifi 6 capable? What options are available for wifi 6 if it is? Lastly, when your computer is connected what is the output of iwconfig or ipconfig?

My thinking is that either your router doesn't care for the new capabilities of your adapter or the adapter is interfering because of the new wifi protocol. This may be a moment where you NEED to upgrade your router if it's not wifi 6 compliant. With a restart and access control off i'm hoping to learn whether it's a hiccup with the cached configuration or a side effect of wifi 6. With iwconfig in trying to see if your adapter is affecting the router dhcp lease (shouldn't, but with new technology it may be causing the isolation). Is your router set to dual band operation?

It has not always been this way, it only started recently. It worked on Zorin 16 fine until two days ago. Nothing new has been installed. It is set to automatic but this issue is occurring even with wired internet not just WiFi. I have tired on each separately and using manual but it is the same issue, as soon as my computer connects speed starts to drop until after a minute the whole network crashes and then it works again once I disconnect this one computer.

lo no wireless extensions.

enp4s0 no wireless extensions.

wlp3s0 IEEE 802.11 ESSID:"SKYVCQUY"
Mode:Managed Frequency:5.18 GHz Access Point: 04:81:9B:D4:C3:05
Bit Rate=234 Mb/s Tx-Power=22 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=49/70 Signal level=-61 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:106 Missed beacon:0

It's hard to tell over text based net speak; but this matches very closely with something I experienced sometime back: A short in the network card was causing it.

I had a similar problem while trying to use an old USB WiFi dongle. It was on the older b standard which slowed the entire network. I imagine a faulty network card could do the same thing.

If i remember correctly it wasn't long ago that you were having issues getting ethernet to work while wifi worked. You ended up installing a different driver. If research other drivers that support your card and attempt to upgrade or downgrade to see if it continues to happen on the alternate driver. As i remember this issue wasn't a problem when it only connected by wifi. Once you verify it's not the driver (does the same on am alternate driver) i'd conclude the same as French and aravisian.

1 Like

So I found out what it issue was. It was a faulty wire which once replaced fixed everything.


I'm happy for you and glad it wasn't a part of your computer that had gone bad. This is one to remember in case similar problems occur. Thank you for sharing that it was writing.