My second storage unit is read-only


So for the past new days I've been enjoying my experience with ZorinOS, this being my first Linux distro that I tried to switch from Windows. I managed to customize it just like I wished and installed every app that I normally use, but I'm a gamer too and that's why I have a dedicated HDD for big games like GTA V. The only problem is that when I mount it and try to create a new folder "SteamLibrary" to store games, it says that it's read only. Can anyone help me? My last option is to reformat the HDD and use the erase option. Thx in advanced for everyone that wants to help.

Yes, you can change the permissions on the HDD for read/write access.
Replace $USER with your actual username and nameofdrive with the actual name of the drive you are changing access to (should be /devsdX something or other):

sudo chown -R $USER:$USER /media/$USER/nameofdrive

The above command will give you ownership of the HDD.

Ok. So I've tried what you suggested to do but I get this message in terminal

chown: missing operand after ‘alex:alex/media/alex/HDD’
Try 'chown --help' for more information.

I deleted my message - there was already -R option.
I think I need a new set of glasses...

You have just HDD in the command:

Please try the following command in terminal to I.D. your drive:

sudo lsblk | grep -v '^loop'

Then replace "HDD" with that "sda" or "sdb"... that you I.D. for that drive /Partition.

Though I see I made a typo in that when I posted that earlier: "/dev/sdX"

Ok. So in the end I managed to solve the problem using chmod . Thanks for the advice and have a great day!

If the problem is solved, please select the post that gave a solution and mark the thread as solved by ticking :ballot_box_with_check:

This will help the future visitor to this forum to find a solution they are looking for.