My upgrade from 16.3 Core to 17.1 core failed, not enough space

My upgrade from 16.3 Core to 17.1 core failed, not enough space warning error message displayed after a while - stating there was less than 1 GB available free (or similar). I tried removing some cache files manually from the cache directory, leaving the message on screen. I should have taken a camera picture,... After that manual operation to make more space, I clicked continue or allowed it to go forward. Eventually it stated that the 17.1 upgrade had failed. Upon rebooting Zorin, it seems to be running 17.1. BUT, I don't really trust that everything happened that should. So what to do now?
After the reboot, there are 3.3 GB free in the root OS volume.
And I've looked in the /var/log/syslog text file... lots of lines with 'upgrade' and 'failed'. Some may be normal...
And I looked in the var/log/zorin-os-upgrader/ folder, file: 1710991794279_99736da7-0dad-4a51-bdc8-477cf50212fd.log (662 KB). Lots of 'failed' there as well, also guessing that some will normal.
Note I had done all the app updates and Upgrader app (tool) update first via menu and GUI screens, so that everything would be 'ready'. However, I did not manually check the amount of free space first -- I thought it would monitor that itself.

Computer: Thinkpad X1 Carbon G6, Ci5, 16 GB RAM, Zorin 16.3 Core is installed in a 'something else' dual boot configuration. The Zorin Ext4 volumes are:
Ext4 GPT 0.95 GB (boot)
Ext4 GPT 23.84 GB (the OS root volume)
Ext4 GPT 37.8 GB (the user home volume)
no swap volume, just whatever the OS decides for a swap file.
Prior to the upgrade, Zorin 16.3 Core was running normally.
So my question: What should I do now? Try to re-run OS upgrade (though it may not offer, since it thinks it is on 17.1). Or some other? I had made a Rescuezilla of my volumes before the process, so I could try a restore and go again after trying to find things to Remove/uninstall (Wine, a windows app or two...).
Suggestions? Thx.

This is good.

I usually recommend a bare minimum of 32gigs but prefer a minimum of 64gigs for Root.
(the times we live in...:expressionless: )

This is ok if used for documents and occasional photos. It wouldn't last long for folks that download movies and games, though.

Your system shows you as now on Zorin OS 17.1 - I would first check that all sources are now set to Jammy and not Focal.

Next, see if any errors:

sudo apt update

sudo apt upgrade

Aside from the "failed" message have you noticed any issues with normal use?

1 Like

HI, I ran those, tho first I ran a couple other steps, to be detailed below. Oh, looks like I did create a (hidden) swap volume of 7.6 GB. And while running the steps, I left open the System Monitor/File Systems so I could keep an eye on changes.
Earlier I missed the swap volume, as I was looking at the EXT4 volumes using Paragon Linux File System for Windows (which works marvelously btw).

lsblk -l
nvme0n1p5 977 M /boot
nvme0n1p6 23.8 G /
nvme0n1p7 37.8 G /home
nvme0n1p8 7.6 G [SWAP]

uname -r = 6.5.0-26-generic

sudo apt-get clean
This results in used space going from 81% to 80%.
Free = 4.6 GB

To clean out old package installers:
sudo apt clean && sudo apt autoremove
displays: 1278 MB disk space will be freed. Y.

  • This results in used space going from 80% to 75%.
    Free = 5.8 GB

Aravision suggested:
sudo apt update
sudo apt upgrade
Result, lots of updates, states 716 KB will be freed.
Result Free = 5.8 GB

I plan to remove the several windows programs -- as I never got them to work on 16.3.
So OODiskImage which I can only see in FSearch and Nemo File manager, some others. Maybe then possibly WINE and Play on Linux if I had somehow messed those up in 16.3, maybe...
I was going to answer last question as yes seems normal, but now the screen snapshot tool has gone missing from the Task Panel on the bottom, so maybe not all well. thx.


  1. the screen snapshot tool, rectangular gray Panel icon is gone,
  2. I ran GUI Menu Software Updater = the software on this computer is up to date. And also,
    Software & Updates / Other Software shows:
    ... ubuntu/jammy main So looks like the correct core.
  3. Check on GUI Menu: Upgrade Zorin OS
    Result is: Youre using Zorin OS 17.1 Core.
    Upgrade to 17.1 Pro or 17.1 Education. (nope, not at this time...)
  4. After a reboot, the screen snapshot tool is still missing. Weird.
1 Like

In Zorin OS 17, the Gnome-Screenshot tool has been removed. Instead, an included Screenshot tool that has been integrated into Gnome-Shell has replaced it.


As @Aravisian explained in Z17 with Gnome 43 the Screenshot Tool is built-in. To use it, You can push the prnt-Button on your Keyboard or You take the Quick Settings Menu:

On the upper left Corner is a Camera Symbol. Click on it and it will start. The Pictures that You will make are landing in /home/[Your-User-Name]/Pictures/Screenshots


Do you know of anyway to change the default folder to something else like for instance /home/[Your-User-Name]/Pictures ?????? .....


Gday @Frog
Thats a good question.
It looks like it's hard coded into the New Gnome 43+ App's.
I see a lot of ppl reverting to the old S/Shot app from the software store & using that.

hope this helps


I believe the EFI/Boot partition should be formatted to FAT32, not an extension?
My setup in "Disks"

1 Like

As far as I know it is not possible to change it. As @Ocka wrote You could use the old Gnome Tool. You can find it in Gnome Software.

Or You could try an alternative Tool like Flameshot, Shutter or CoreShot (this only works on X11).

1 Like