My username does not appear in the system's user list

My user does not appear in the system's user list.
In the user settings it only says "No users found"
On the system login screen I have to enter my username and password every time I log in. Previously, the login screen showed my selected user, simply typing the password.

Have you set up automatic login and this has happened since?

Do you know what you have changed (or updates)since you were last able to login from your User prompt?

Are you on Z17 Core?

I didn't configure automatic login.
I suspect it was when I tried to install ZSH and then uninstalled it.
I'm on Zorin 16.3 Core

Does it work if you run through a terminal? Do you see any error messages?

gnome-control-center user-accounts

It doesn't work like that either

Do you still have root access with your sudo password?

Yes, I still have it.

In this case, I would suggest re-adding your user account to the user list:
https://help.ubuntu.com/stable/ubuntu-help/user-add.html.en

I had already tried to do this but when I enter my username the system shows this message:
Sorry, the username provided is not valid. Please try another one.
The fact is that I would need to create another user for myself with another name, but I don't want to do that.

With the help of this post I managed to fix the issue of my user not being listed in the system.

But my username still doesn't appear on the login screen.
I'll look into this, but I suspect maybe now it's just some silly GDM configuration.

Have you tried reinstalling gdm3 and reconfiguring it?