My wifi is connected but showing question mark randomly appears in the wifi icon (zorin 17 pro)

My wifi is connected but not working ..a question mark is randomly appears on the wifi icon. Please help me, I don't wanna go back to windows, I use zorin 17 pro


Connected through Wi-Fi only means there's a connection between the computer and the router but not necessarily internet access. First, confirm that your device really doesn't have any internet access by trying to visit any websites, running software updates or other programs that need internet access. If some things work but not others, that already may give a clue as to what's wrong.

Do you have other devices connected to the same router? Try them as well; do they work? Try using an ethernet cable if you have one as well, to rule out any problems with the Wi-Fi itself.

You should also try to disconnect from the Wi-Fi entirely (forget the connection) and reconnect. This type of dumb attempts work more often than they should :smiley:

I don't have access to any web page really, I can't perform program updates or software updates.

I have devices connected to the same router working perfectly. I'll try using ethernet cable

7min after
I can't test with the cable because the router or PC input doesn't work

If you run ip a in a terminal do you see an IP address assigned to the either ethernet or wireless interface? If you do, try to ping another device on the network see if that at least works.


sudo modprobe -v ath9k

Get it working?

I've tried 2-3 times nothing changes, the command don't show any comment

This usually means that the module is already loaded...
Let's try

sudo modprobe -r ath9k

sudo modprobe ath9k

If need a file to help, I can use the other system to download it, it just cannot require the internet to install, due to the system not being able to access the internet, I have a dual boot with Windows, but I want to abandon Windows, I don't like it very much, I'm new to Linux

Can you show the output of:

grep '' /sys/module/ath9k/parameters/*

I think it's worth trying this out:

Edit file /etc/modprobe.d/ath9k.conf (create if needed) and add a new line:
options ath9k bt_ant_diversity=1, reboot and try again.

EDIT: Does the Wi-Fi work / has it ever worked at all? Or is it sometimes that it stops working?


The mark of question on reboot has gone, what is very nice, but internet still not working, I can't access pages, update programs or software. I needed to create the file because I didn't have one.

In second reboot the mark of question come back

Taking some advice from another thread over on the Mint forums, you may also need to enable btcoex_enable as well; same procedure, restart and try again. I hope this one works, otherwise I'm out of ideas :confused:

1 Like

Thank you, I'll format it, it's what I least wanted, but it's the way

Have you tried switching kernels, yet?

Don't remember if I try, but I've already formatted

So did you get it work with this last change? If not, might be a good idea to revert the changes back to 0 just in case.

I've already formatted, works fine again.

1 Like

Today I discover what happens, after install portmaster again and have the same problem, it's portmaster problem, lol, thank you guys, If someone knows how to fix the conflict with portmaster.

1 Like