My WIFI keeps disconnecting on Zorin OS

Basically title, it has been like this ever since i installed Zorin OS, i didn't try any fix yet. it's not a router problem, cause i have a dual windows boot and it never disconnects.

There are a number of threads on the subject of wifi disconnecting here on the forum.
Simply enter "wifi disconnecting" into forum search to reveal them, including this one: Wifi disconnecting

It will help if you can give us details of your hardware, particularly the network/wifi items.

1 Like

I had that problem... turns out Xfinity had moved into the neighborhood with their WiFi offering (the nearest WiFi hotspot was just across the road from us, there was one at the end of our block, then a couple blocks away there were dozens of them), and they were flooding the channel I was using with much higher power than my little consumer-grade WiFi router could manage, which drowned out my signal.

I moved to another WiFi channel, and it started working again.

First, post the results of sudo lshw -c network.

  1. Make sure you've got the latest WiFi drivers installed for your WiFi adapter.

  2. Make sure you're running on a relatively quiet WiFi channel.

  3. Check your router's ARP timeout (lease timeout). Some are set to as low as 20 minutes... I recommend 1 day. May be that Windows is just faster at renewing the IP lease, so you don't notice the connection drop.

  4. Windows may be running a 'keep-alive' ping to the router so the connection doesn't drop... if you see any 'keep-alive' setting in your router, disable it or set it to a high timeout number. Or create a script to ping the router with a keep-alive packet from Zorin OS at an interval less than the router's 'keep-alive' setting.

  5. Run dmesg -f kern and look for any messages that state something like "deauthenticated".

  6. Run dmesg | grep wlo1 where "wlo1" is the designation of your WiFi adapter. Look for error messages.

  7. Run dmesg -w and watch the logs in real-time. When your WiFi drops, you should see a new entry.

  8. Disable WiFi power management.
    /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    wifi.powersave = 2

    ... where:
    0 = use the default value
    1 = don't touch existing setting
    2 = disable powersave
    3 = enable powersave
  1. Switch from 5 GHz to 2.4 GHz WiFi channel.

I have the same issue as the person above. My Wifi randomly stops working after 45 mins - 1 hour and I have to restart to get it to work again. Also, it does not show visible networks once disconnected and sometimes the message- active connection of network failed also shows up. Here is the result of sudo lshw -c network

*-network
description: Ethernet interface
product: RTL810xE PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 07
serial: 8c:ec:4b:13:20:59
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.15.0-67-generic firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=twisted pair
resources: irq:16 ioport:d000(size=256) memory:d2204000-d2204fff memory:d2200000-d2203fff
*-network
description: Wireless interface
product: QCA9377 802.11ac Wireless Network Adapter
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 31
serial: b0:52:16:47:4f:39
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath10k_pci driverversion=5.15.0-67-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 ip=172.16.139.83 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:132 memory:d2000000-d21fffff

If it is failing at a set time then maybe it is sleep or power saving that is the trigger.
Have you looked at the list of actions by Mr_Magoo above your post?

Also maybe this: Prevent network to disconnect in sleep mode - #4 by Aravisian