Nahimic Driver for Zorin

I have an MSI GE75 Raider laptop that i have removed windows and moves to Zorin. It’s been two weeks and all is working well. I love the OS and recommend it to all.

I had been using earbuds for sound and all is fine; however, when I unplug the earbuds the sound stops working. The laptop uses Nahimic drivers in windows. I have read the issue is commonly found in most Ubuntu bases distros. I can’t find a way to solve the issue. All attempts I found online just borked my sound up completely and I had to use Timeshift to get back to baseline only to try again.

Does anyone have any information to fix this problem? Again, it’s an MSI GE75 Raider laptop using Nahimic for sound.

Thanks!

Have you yet tried Kai Heng Feng's patch?

sudo add-apt-repository ppa:kaihengfeng/fix-lp1869819

sudo apt update && sudo apt install --reinstall pulseaudio

Thanks for the reply @Aravisian. I appreciate it. I just tried it but no luck found. The headset works fine out of the jack but when unplugged there is still no sound.

I have even tried the sudo alsamixer suggested at many sites.

The search for fixing sound continues!

I wonder if this is more exclusive to the Nahimic set, then...
There was a bug that needed to be patched in pulseaudio where unplugging the earbuds or headset could result in muting the whole system:

The patch had already been accepted into Pulseaudio by the time you had Zorin OS 16.2. But it was worth trying, just in case (Regional servers or the like)...

I admit, though... I struggle to understand how a specific Earbud (Nahimic) could cause this issue even as it works properly otherwise.

You should run:

sudo add-apt-repository --remove ppa:kaihengfeng/fix-lp1869819

When it comes to fixing Pulseaudio; the search always continues...

2 Likes