Need help, trying to move away from Windows

Hi, so in windows I am able to enable 12bit color and Full RGB. (I own Zorin OS 17.1 Pro) Is there any way to do that on zorin, if not zorin than any other OS's will do and I'll just use zorin for my laptop. I just can't stand windows direction right now with windows 11 24H2 and want to game on linux.

My GPU is 7900xtx xfx, cpu is 79503d

If all else fails I am fine with 10bit, but I need Full RGB

Welcome to the Forum!

You could look if You can adjust that. Go to the Gnome Settings. There You have the Colors Menu where You can add Profiles for Your Display. Maybe You finde there what You need.

I've tried both profiles on and off. Restarted and everything. Does nothing. Still stuck with limited range, 8bit, and YCbCr 420.

Look here:

Click o the first marked Position and then You have tthe Possibility to add a Profile see on marked Position 2. And then opens a Window with multiple Options:

Scroll trough the List a look if there is the right Thing for You.

It looks right and I see rgb settings, tried all but to no avail. (Restarted and everything just in case) Even installed the icc profile from my mointors website for the PG42UQ. But that didn't work either.

ZorinOS uses wayland so I would need to know how to enable these on that. (Using an all AMD system)

Wondering if you need to change kernel?:

" To get an AMD Radeon RX 7900 XT(X) to work with Ubuntu 22.04 LTS, you can follow these steps:

  1. Install the latest OEM kernel available by running the command:
sudo apt install linux-oem-22.04c

Download and install the latest kernel firmware from here by running these commands:

wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-20230919.tar.gz
tar -xf linux-firmware-20230919.tar.gz
sudo cp linux-firmware-20230919/amdgpu/* /lib/firmware/amdgpu/
sudo update-initramfs -uk 'all'

Install the kisak-mesa PPT by running these commands (this PPA will take care of providing the latest stable mesa and llvm15):

sudo add-apt-repository ppa:kisak/kisak-mesa
sudo apt upgrade

Ensure there is no modprobe blacklist for amdgpu by running the command:

sudo rm /etc/modprobe.d/blacklist-amdgpu.conf

If you use Xorg instead of Wayland and have the issue where the mouse cursor is invisible, you can try to create the file /etc/X11/xorg.conf.d/99-modesetting.conf with the following content:

Section "Device"
      Identifier "modesetting"
      Driver "modesetting"
EndSection

This should make the latest LTS work with your hardware.

Answer from Roberto Leinardi on askubuntu.com"

I'm just gonna stay on windows. I just don't see this going any where, and this will be one of those things were nothing works. Appreciate the help but so far linux isn't there yet for the gaming side.

I beg to differ on the statement of gaming. Cyberpunk 2077 game runs faster on GNU/Linux (Fedora spin Nobara) than on native Windows! (Reported in Linux Format Magazine a few months ago.)

http://news.tuxmachines.org/n/2023/09/29/Cyberpunk_Phantom_Liberty_Runs_31_Faster_on_AMD_GPUs_in_Linux_C.shtml

2 Likes

Whe You use something with a more Gaming Focus I would suggest that You try Nobara Linux. That Distro is based on Fedora and has a Gaming Focus. It has optimized Kernels too.

1 Like