Need help with power management (not working with games)

Hi, everyone. I need help, please. With regard to power management, I have my PC set to "balanced." I have the monitor set to go off after 5 minutes of inactivity, and the PC itself to suspend after 15 minutes. (Speaking of which, when I first installed Zorin OS, I noticed that the PC suspend mode was OFF by default - why? Why did the Zorin developers decide to do it that way?) Now, with these settings when using the computer under normal, day-to-day use on the desktop, they work fine.

But when I play a game on WINE or as a native Linux game, the power still goes off. Why is that? I didn't have this issue on Windows. I have played around with the settings, and have found that if I disable the power management for the monitor, the monitor stays on. When I have the computer set to suspend after 15 minutes, it suspends when I'm in a game. I have tried using Caffeine, but it does not work for preventing the computer from entering sleep mode. How do we resolve this?

Thanks to all.

I cannot fathom why it would be On by default. This is a user choice item and having it enabled would infuriate a lot of people and result in a much sharper retort.

Your request is 100% reasonable. You want power management to work normally at all times.
In Windows, everything is standardized under One Controller: Microsoft.

On GnuLinux with WINE, you are running a compatibility layer to run MS Windows applications on the Linux system. This adds a lot more complexity and room for conflicts or errors.

The way Caffiene works is that it simulates mouse movement, thereby preventing the system from sensing "inactivity".
If this occurs on games - including non-WINE games, are you using a Game Controller instead of Mouse and Keyboard?

Even though you checked your Display inactivity settings; Did you check screensaver settings?

1 Like

Hi, Aravisian. Thanks for replying. Read on, please ...

I understand that, but please also note I said "native Linux game," too.

So we're talking about WINE and Linux games. Just wanted to be clear.

Yes. Microsoft Xbox One controller (wired). I also use a keyboard and mouse for Quake (WINE). That one does NOT go to sleep. No problems. For the other WINE and native Linux games, they go bye-bye.

No. I did not. I will look shortly and reply here again.

Very sorry - I cannot find the screensaver settings anywhere ... ?

In this case; can we clarify whether the "inactivity" is only being registered when a controller is being used?

Hi again, Aravisian. That's right. Only when a controller is being used. Yes.

Even Windows does not, tho when watching Wine logs closely, you'll see that games send an API command to Windows to explicitly inhibit the screen saver. Native Linux games should do the same, desktop environments should already have an API for that (most media players already do that). If your report is about games running in Wine (or Proton), you should report there: The API call for inhibiting the screen saver needs to be propagated up to Xorg or the desktop environment.

Developer suggests the following:

I may have found a solution. Espresso through the Extension Manager (for Gnome). I will test this further later, and will report back. In the meantime, thanks for replying. Will get back to this thread later. Gotta run.

Update:

Have tried Espresso through the Extension Manager. It works perfectly. As long as I pick the games for it to work with, everything is fine, and works as it ideally should. I tried two games - one through WINE, and another that was a native Linux game. Both worked. The screen did not dim, nor did the PC suspend itself while I was playing the games. Once I exit the games I picked for Espresso to work with, that's it. The computer resumes normal power management function. I am going to claim this as the solution. I hope everyone benefits from this. Linux gaming has come a long way since the last time I had a Linux OS. It's not perfect, but still a big improvement. Perhaps the developers of Zorin OS will consider adding Espresso to Zorin OS as an included system-level application? I think that'd be appreciated.

2 Likes

Hello there,

I understand the frustration you're experiencing with power management while gaming on Zorin OS. It can be a bit tricky to find the right balance between saving power and ensuring an uninterrupted gaming experience.

Regarding the default suspend mode being off, the Zorin OS developers might have opted for this setting to provide users with more control over their power management preferences, as not everyone prefers their system to suspend after a certain period. However, it's always good to have customization options to cater to different user needs.

Now, in addressing the issue with your monitor and PC entering power-saving modes during gaming sessions, you might want to explore a few solutions. Firstly, check if your game settings have their own power management configurations. Some games have their own independent settings that might override the system preferences.

Additionally, you can try using the tool you mentioned earlier, twitchclipdownloader.xyz, as it might have features or options that could influence power management during specific activities like gaming. It's always worth experimenting with different tools to find the right combination that suits your needs.

If Caffeine isn't working as expected, you may want to explore other alternatives like using the "xset" command in the terminal to modify power management settings for specific activities. Be cautious while tweaking these settings to avoid unintended consequences.

I hope you find a solution that works for you. Feel free to share any updates or specific details about your system setup for more targeted assistance.

Best regards,
[Thomes james]

1 Like

That would be me.
I need my machine to stay active even if I am gone for 12 hours.

1 Like