Need ZorinOS support Intel Pentium Dual-Core Mobile T2060

I am unable to install ZorinOS Lite on my ancient laptop. The Acer Aspire has the Dual-Core Mobile T2060, a 32-bit chip. I believe that my problem lies with the graphics drivers provided in the Live USB that I created using 'Startup Disk Creator'. The machine will boot all the way to the desktop if I select SAFE GRAPHICS after displaying some wild graphical noise. It will not complete the boot process if I select 1. from the Install/Try menu. With safe graphics, the external monitor is not supported. But the biggest deal is that I am never given the option to install. I can only run from the Live USB stick. The machine is using the graphics support built into the Intel CPU. This machine is from 2007 and works very well hardware-wise, but the Vista OS is a disaster. Any and all suggestions welcome. BTW I am running ZorinOS 15.3 Ultimate on my AMD Ryzen tower.

How did you burn the USB?
How much RAM is on your Aspire 2060?

1 Like

At least it will work with Linux Lite.
https://linuxliteos.com/hwdb.html

Search with keyword: Intel Pentium T2060

[edit] Unfortunately 32bit version is no longer supported :frowning:

32bit ISO

There will be no 32bit ISO from Series 4.x onwards. If you still need to run a 32bit operating system, our Series 3.x is supported until April, 2021. Download it from here.

[more edit]
From the above page, I found graphics is GMA950.

CPU: Intel Pentium T2060 1.6 GHz
Video Card: Intel GMA 950

1 Like

I made the USB stick using Startup Disk Creator because it came pre-installed with ZorinOS. There are 2 gb of RAM. ZorinOS runs ok from the stick, but there is no opportunity to install to the SSD.

1 Like

Yes, that's right. Intel Graphics Media Accelerator 950. I believe this is where the conflict lies. I could look for a driver if I could get the ZorinOS Lite to install. There's no point to changing the driver while I'm just running in Live mode.

Quite old thread (then again, your machine is also very old)

Good lead. Since Zorin OS 15 Lite is based on Ubuntu 18.04, might try "acpi_osi=! i915.modeset=1 nomodeset quiet splash" if the above does not quite work.

I'm sorry, but I'm not quite seeing what I need to do. If I could get Zorin lite installed, then I could edit the grub record. But I cannot. I can only run in Live mode. The menu that would allow me to install never appears. I get the menu that allows me to choose Try/Install, but then it just boots to the desktop ... that is, if I choose Safe Graphics. If I don't choose Safe Graphics, it doesn't boot at all.

1 Like

I'm sorry, I was not clear.
You can edit the grub in Live mode and see if it works. If it does, you can install, then edit the Installed Grub and then boot up normally.
You must edit grub in Live USB prior to booting.

To do this, hit the e key at the bootloader menu screen (the one that offers safe graphics.) That will bring up the Grub editor. The Live USB version looks almost unrecognizable, so the easiest way is to Scan The Page looking for quiet splash. When you find it, just place the above in front of it. Then exit and proceed to boot up.

Thank-you Aravisian. I must have done something wrong since it did not work. Apparently, one edits the grub menu by pressing TAB instead of typing e on my machine. When I did so, the following line appeared at the bottom of the screen: > /casper/vmlinuz boot=casper quiet splash --- initrd=/casper/initrd.lz4

Using the arrow keys to position the cursor between casper and quiet, I entered what you mentioned in your note above. I then hit ENTER and the machine attempted to boot. However, it behaved exactly as if I had chosen 1. from the Try/Install menu. That is, about 25 lines of messages were endlessly dumped to the machine with a screen flash between each. PLEASE NOTE that in your note that there is a space between the acpi_osi=! and i915.modeset=1. I entered that space. I then tried it without the space and it acted as though I had chosen SAFE GRAPHICS. It booted directly to the desktop giving me no option to install. Before the desktop appeared, as always it dumped tons of data to the screen much to rapidly to read any of it.

1 Like

The space must be there. That it seemed to almost work is interesting.

it may be the NoModeSet that was working, so, let's try just that.:
nomodeset quiet splash

If no good, then can you try FrenchPress' original suggestion of just i915.modeset=1 quiet splash and see what happens?

Ok. I tried just nomodeset and it almost worked exactly the same as when I put the entire acpi_osi text in. I had already tried just putting i915.modeset=1 which did not work. Anyway, I'm suspecting that I'm seeing the second menu screen in a horribly distorted fashion. It displays for roughly 2 seconds, then the construction of the desktop begins. If I knew which entry installed, I could quickly arrow down and hit enter before the 2 seconds expired.

Well, choose "Safe Graphics" and entering "nomodeset" into grub is mostly the same thing - but it was worth testing, in any case.
When it boots to the desktop, In Try Zorin MOde, does it behave normally at that time?
Are you able to access the Zorin OS installer icon on the desktop?

I didn't know that install icon was there! My vision is impaired. I am running it right now. Everything appears to be operating normally. The screen resolution is even correct for this screen. I'll let you know what happens.

1 Like

I have successfully installed ZorinOS 32-bit to the internal drive. However, booting is duplex. First, I boot, but reach a blank screen that flashes once per second. I must depress and hold the start button to shutdown the machine. Second, I boot again and this time get a recovery menu. I choose the first recovery mode and the desktop appears. It functions normally. The next time I boot the cycle repeats: I get the flashing screen and must boot using recovery mode again. I have not been able to edit the grub menu. I'm not quite sure when I must enter the 'e' or maybe the TAB. Is it when the screen is blank except for a border?

Now that Zorin OS is installed, you can edit the Grub Menu much more easily. After booting into Zorin, from terminal you can edit using the In-terminal Text editor:

sudo nano /etc/default/grub

Or the GUI method:

pkexec thunar

Navigate to Top Level by clicking the Up Arrow on the Toolbar several times until you reach Root. Double click /etc directory. Then /default directory and finally, the grub file.
Grub will open in a Text Editor allowing a Familiar interface.

I used the pkexec thunar method and now have the grub file open in the in-terminal editor. Every option is preceded with a keyword phrase that begins with GRUB_. I'm not sure how to put acpi_osi=! i915.modeset=1 nomodeset into this file. I am afraid to experiment here because I might totally lose my ability to boot into ZorinOS. Is there a keyword phrase that I need to use?

I think you should look for:
GRUB_CMDLINE_LINUX_DEFAULT=

1 Like

Duplicate this appearance:
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! i915.modeset=1 nomodeset quietsplash"

Hurrah! I added the line exactly as you, Aravisian, put it in your latest note and ran sudo update-grub ... and it works! Not only that, it now supports the external monitor again. It now dumps tons of text to the screen during startup that it didn't before, but I don't care. Thank-you for taking time to help me with this.