Neither EEtcher or Rufus will create bootable USB

Hi: I tried out Core and liked it. Paid my money for Pro. So, the Pro .iso wont fit on a standard CD and I'm not about to buy two layer - at least not yet. Tried several times to get Etcher on a USB stick. Doesn't work on laptop. Tried Rufus, same result with a message saying "error no such partition. Entering rescue mode...
grub rescue>"
What does it all mean? It is Linux speak and I'm a raw recruit. Why doesn't it just upgrade from Core like any sensible operating system would do - dare I say Windows? I see that the 'big man' is working on it. Work harder, you got my money.
So, leaving aside the comments, what does one do to install Pro?

You can start the Disks application, select the drive you want to 'burn' the .ISO file to (it'd be best to use a blank USB stick), then click the "Gears" button, select "Restore Partition Image", select the .ISO file you want to 'burn', and set it running.

Then reboot the computer, boot from the USB stick you just 'burned' the .ISO file to, then select "Install Zorin".

Thanks but more questions! Which Disks application? Is this Linux, which I don't have anymore. Wiped it off just in case that was the non-install of Pro problem. Etcher doesn't have a 'gear' and neither does Rufus. I suppose I could reinstall Core, put image on the stick. Then wipe Core off again. Pro wont up grade if the Core is on the computer. Ignores all my boot instructions, goes straight to the SSD and boots up Core.
So, are you suggesting that if I reinstall Core, use Disks to create a bootable USB and just reboot from the USB it will install Pro. Don't think so given all the complaints about being unable to install Pro over Core.

Yes, gnome-disks is the application name, gnome-disk-utility is the package name.

tput rev;read -p "Command? " in;tput sgr0;sudo dpkg -S */$in$* # Show which package a command belongs to

Command? gnome-disks
gnome-disk-utility: /usr/bin/gnome-disks

The installation should wipe the drive in setting up the new partitions, so there shouldn't be a problem installing over any installation, whether that be Windows, or any flavor of Linux.

Users that choose Zorin OS Pro also receive Installation support directly from the Zorin OS Developer.
Please submit your request (please scroll down to Contact Us and select Pro Support) as they probably are the best ones to help you. From what I read in your O.P., it sounds like the large file size for Pro is what is causing the issue with Rufus.
You might try Unetbootin or Multiboot or even Ventoy.

Incidentally, yes; you can currently install Zorin OS Core on your machine and then "upgrade" it to Pro using your Pro .iso. That, too is an option if it is easier for you.

1 Like

Hi: Thanks for replies. Now things are working from the usb stick and the answer is really, really dumb. On the HP laptop on which I'm trying Zorin there are four usb ports. The one I'd previously tried produced the errors. This time I tried the port on thee other side and it booted and installed. I even checked the manual and it doesn't mention any differences in the ports. I've been 'into' computers since the early '80s and never met this before. You live and learn.
Thanks for suggestions, didn't know you now could upgrade from Core, useful to know.

1 Like

The upgrade option is still in the works. A full reinstall is still the recommended way of upgrading to a different version of Zorin.

There are two different "Upgrade" Options being discussed at this point and some clarity is needed between them.

Upgrading from Core to Pro for the same release can currently easily be done using your Pro .iso

Upgrading from One Release To the next (For example Zorin OS 16 to Zorin OS 17) is currently in active development and is not yet available.

1 Like

Download Ventoy and install on usb. Drop the .iso onto ventoy and boot from usb. I have at least 8 diferent distros and can boot every one. No need to burn usb.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.