Nemo as default replacing Thunar

I uninstalled (purge) and reinstalled Nemo but I don't think that has any implication on the following because the same observation remains. However, I noticed the copy error isn't uniformly applied. The problem seems to only occur in one type of copy.

Problem: Desktop -> Open folder.

No problem:

  1. Desktop -> Desktop
  2. Open folder -> Desktop
  3. Open folder -> Open folder.


I'm going to mark A's last suggestion as solution since all those changes are still in my system and I don't plan to remove them. Pretty sure they helped me to get to this state which I am happy to live with.

You are more generous than I am.

What happens with desktop > open folder if prior to attempting transfer, you open alt+f2 and enter in nemo --replace?

Nothing. The alt+f2 accepts the input and closes. Then, copying from desktop leads to the same error.

I am honestly baffled. I used to use Nemo on Zorin Lite Desktop (Not Cinnamon) and all of the above should have worked. I must be missing something. A step somewhere.
I just tried searching the web but... Not helpful...

1 Like

We have been researching the issue but haven't been able to find a full fix for it. As XFCE isn't designed to work natively with Nemo, it's unlikely that this issue can be resolved in a reliable manner. Because of this, we would recommend you to continue using the default Thunar file browser in Zorin OS Lite.

However, the following answer might be helpful to you:

1 Like