Nemo as default replacing Thunar

Using Settings -> Preferred Applications, I changed from Thunar to Nemo. Now when I try to copy a file from my desktop into a folder on the desktop (I didn't try others since I keep most of my stuff on my desktop), I get "Error when getting information for file No such file or directory". When I switch back to Thunar, everything works fine.

Nemo needs to be configured to handle the desktop.

xdg-mime default nemo.desktop inode/directory

Now, check

xdg-mime query default inode/directory

It should list

nemo-desktop

If it lists more, you may need to annotate those items and repeat "xdg-mime default nemo.desktop ______" filling in the blank.

In xfce4-session-settings under autostart add nemo-desktop.

Check everything to ensure all is working properly.

In response to xdg-mime query default inode/directory, I get nemo.desktop rather than nemo-desktop but I tried both ways under the nemo entry I added under the autostart menu. Rebooted and in both cases I still get the error.

Yes, I get into habitual typing... I typed .desktop in one spot and -desktop in another. It just goes to show how poor my brain is.
You already ran exo-preferred-applications to set it as default, right?
Navigate to ~/.local/share/applications/mimeapps.list and check the entry for inode/directory=

Otherwise, you may need to try this fix (it is for nautlius, but the principle is the same as Nemo is forked from Nautilus.

We all make mistakes, try to not beat yourself up about it too much buddy lol.

Truth is, Aravisian is pretty amazing, cause here's a guy who is helping other's out, while he's also busy working in the shop on custom cars.

Thats a lot of info to juggle around in your head at once. Multi-tasking is an art, and you do it well buddy. :+1:

Aside from moving some scrap metal out for a scrapper to happily haul off, most of today I have been slouching.

Between the terminal and you, I was going to say the terminal had it wrong. But oh well.

Yep, it's already default application.

I only have ~/.local/share/ no applications folder in here. I found mimeapps.list under ./config and it has inode/directory=exo-file-manager.desktop

In your last sentence you missed providing the link for the fix (I assume you intended to link the nautilus fix).

My guess is that you're working yourself to death and are tired (in spite of your own "slouching" determination). Just fyi, this isn't important, far from it. And I can always go into Thunar until it is a better time for you to respond.

LOL, I hurt myself.

There you go, that should be inode/directory=nemo.desktop

I did...

Thanks for persisting.
Unfortunately, that error stays.
I can't implement the link's proposal either since other than PlayOnLinux virtual drives, I don't have a dbus-1 folder anywhere on home and in the root subfolder, I don't have org.freedesktop.FileManager1.service.
Running ln -s /usr/share/dbus-1/services/org.freedesktop.FileManager1.service ~/.local/share/dbus-1/services/org.freedesktop.FileManager1.service confirmed what I found.

I have not read this thread, yet, just tossing it out here as it may solve or help:
https://forums.linuxmint.com/viewtopic.php?t=179919

No luck. I tried this too How to Install and Make Nemo the Default File Manager in Ubuntu - also no luck. Thunar's revenge.

PS - For the steps on the LinuxMint forum, I had found the root mimecache contained inode/directory=thunar.desktop;Thunar.desktop;org.gnome.baobab.desktop;org.xfce.Catfish.desktop;nemo.desktop; where I edited out everything except nemo.desktop. The home folder mimecache was already correct.

Yes, it defaults to Home, first.

Hmm... I am stumped.

Thanks for trying. Since it's Ultimate, I sent a request to Zorin Installation Support - Zorin OS

As this is a user Modification, I doubt this really falls in the warranty...

I am sure you have Dconf-editor installed. Running that, check
org > nemo > desktop
computer-icon-visible -True
home-icon-visible - True
show-desktop-icons (allow Nemo to manage the desktop) - True

EDIT: It seems Thunar needs to be told to not to, as well...

Open Thunar and navigate to the 'advanced' tab in preferences, and click on 'configure
management of removable drives...', indicating that Thunar will not handle removable drives but will continue to handle volume management. Go through the "storage" tab and uncheck the boxes in removable storage.

https://www.ezeelinux.com/talk/showthread.php?tid=275

Correct, but it doesn't hurt to ask.

First two were false, so I set them to true. Last one was already true.

Thanks for all this searching. I did the Thunar steps and also confirmed the Nemo preferences as suggested in the ezeelinux.com link. The enigma remains.

Did you reboot?

I got lazy and just logged out and back in. But I reboot after reading your post. Still the same but now I have an extra wifi icon. Sweet.
tray

Just had a thought. You use Cinnamon DE, right? And I think you wrote it is lightweight too. If I use that instead, this problem should go away since Nemo is the default there. Correct?

I believe it would since it is not an issue I have. That said, I would call Cinnamon a "Medium-weight" not a light weight.

Just make sure to add some cinnamon to your morning coffee, while your using Cinnamon DE, it feels only right. HEHE :coffee: