Nemo: File Manager Force Close When Selecting Phone's IP to Browse Files

When using Nemo File Manager to browse files on phone after mounting with ZorinConnect - Nemo file manager force closes.

  • When clicking on the "phone storage" option in ZC settings/menu as well as with any other open action via default file Manager of Nemo - the File Manager window flashes open, then closes instantly.

  • I've been previously able to use Nemo File Manager to browse these phone files after mounting with ZorinConnect.

  • Checked firewall rules - toggled on/off - same result, no change.

  • Checked VPN rules/whitelist - same result, no change.

  • Checked Nemo preferences, plug-ins, etc. Not able to locate option(s) for configuring mounted drives

  • In-built Nautilus File Manager still installed, tested and was able to view phone files with Nautilus File Manager.

  • ZorinConnect settings on phone have been checked multiple times to verify all plugins settings set to enabled, including "Filesystem expose".

Another issue I'm experiencing is intermittent connection with phone via ZorinConnect. It will be active and in the system tray indicating the normal "ready" status icon, but then will randomly drop the connection. Unsure if related to what's causing OP issue with Nemo.

With all the above taken into account, requesting assistance with finding out reason Nemo File Manager will not allow me to view mounted phone's filesystem.

I use Nemo File manager on Zorin OS. I do not use Zorin Connect, since i use Zorin OS Lite.
I use KDE connect.
Even so, trying out your issues, I did not experience the same.
You also mention that Zorin Connect is dropping connetion.

I agree with your curiosity as to whether the issues are related - in that if the Gnome-Shell-extension for Zorin Connect is experiencing breakage.
Given that I am not using gnome or a gnome-shell-extension; it's hard for me to test.

You might try installing kde-connect and seeing if you experience the same troubles with it on Nemo...

Pretty sure I found the issue.

Suspect it has something to do with Google Play further restricting ability to be able to expose the Android file system for All Files access.

The reason I believe the File Manager insta-closed is because of the inability for KDE Connect, GS Connect, Zorin Connect to actually access the requested directory (tried all three). This makes complete sense to me as I've seen similar behaviour throughout my years fiddling with computers.

Desperately waiting for any of these productivity/connectivity applications to be updated or patched to allow this functionality again. Sharing files between phone and computer was literally the only feature I consistently used.

Other users experiencing the same issue - with an easy-to-miss link in OP to a propsed/possible fix to Manage all files on a storage device from the Android dev page.

I don't know a lot about how the implementation would work, but I really hope that the proposed fix will be something that Android devs and KDE Connect/variant devs are hot on the trail to this change made by Google.

Thoughts? If not, thanks for making the time to reply.