Network not connecting after install on macbook 2017

I installed Zorin on MacBook 2017, and encountered the problem related to broadcom 802.11 not being recognized. I have tried a direct line from the router to the computer using a special connection (failed). I purchased a Penguin Linux external wifi router (failed). I cannot run update - because, there is not a connection (the date on my new Zorin system has not changed, meaning there is no connection). There is no Secure Boot on this version of Zorin. When I type lshw -c into the terminal, I get the following:
Hardware lister (lshw) -
usage: lshw [-format] [-options ...]
lshw -version

format can be
-html output hardware tree as HTML
-xml output hardware tree as XML
-json output hardware tree as a JSON object
-businfo output bus information

options can be
-class CLASS only show a certain class of hardware
-C CLASS same as '-class CLASS'
-c CLASS same as '-class CLASS'
-disable TEST disable a test (like pci, isapnp, cupid, etc. )
-enable TEST enable a test (like pci, isapnp, cupid, etc. )
-quiet don't display a status
-sanitize sanitize output (remove sensitive information like serial numbers, etc.)
-numeric output numeic IDs (for PCI, USB, etc.)
-notime exclude volatile attributes (timestamps) from output

How can I get a connection?

Please try

sudo lshw -C network

You should be using bcmwl-kernel-source.
If you cannot currently use hardline or hotspot to get a connection, you may need to use a networked computer to download the packages, then a USB Stick to transfer them:

On your affected computer, first run:

sudo apt remove --purge broadcom-sta-dkms broadcom-sta-source broadcom-sta-common bcmwl-kernel-source

Once complete, launch and run the installers from the two links above and install onto the affected computer.
Reboot and check network connection.

Installed the ...Oubuntu7~20.04.3-amd64.deb.html after removing Broadcom. Used the Linux Install Tool on Zorin after moving the files using a flash drive, used password, and rebooted. However, in settings the WIFI can now find the network, but cannot log into it, it will not accept the WIFI password, saying the network is encrypted. Signal strenght is excellent, but last used is Never. I also tried an external wifi adapter from Penguin, their latest, it runs into the same problem.

I would have thought the last suggestion here except for your statement quoted above.
Are you using a VPN, LUKS or any other encyrption?
Did you download and install Zorin OS .iso from a primary Zorin OS Mirror?

I did try to install Proton VPN initially, at first boot up. And, I do see in terminal when i tried "sudo apt-get update":
W; Failed to fetch https;// Temporary failure resolving ''

Just tried the ASCii converter to convert the wifi password to ASCii and no access.

What is the output of

nmcli device

(Guard any sensitive information if any).

There is not much text to nmcli device from terminal, but, essentially, it says something close to below. I have made some modifications for privacy.

ip**** dummy connected --protection
***** wifi disconnected --
****** wifi disconnected --
******* wifi-p
* disconnected --
lo loopback unmanaged --

I did some research and found that I needed to delete first line in the output

So, I ran the delete code from another search and it was deleted. After, reboot, still says there are network problems. Says I need the password or encryption keys and I know the password is correct.

It sounds like you may have secure boot enabled in your BIOS. Is this the case?
If so, did you setup MOK upon installation of Zorin?

If so - are you dual booting with Windows?
If you are not... I recommend disabling Secure Boot. It is for Windows Only.

Those are great ideas. My understanding is that this Zorin does not have secure boot. Nonetheless, I am not dual booting. I do not think MOK is installed on this system, as I have tried to run that to turn off the secure boot and there was some kind of error, which is when I searched and found out there was not a secure boot. In the meantime, I did contact ProtonVPN. Since Zorin is not officially covered by ProtonVPN, they said they are sorry for the inconvenience and will keep working on it to bring Zorin and other OS up to date.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.