Network problems with Chromium based browsers - Zorin OS 17.1

Hello,

I have problems with Chromium-Based browsers in Zorin OS 17.1:
For some seconds the network connection disappears. I always get the error message that there is no network connection (ERR_NETWORK_CHANGED) for some seconds before it works again.

I normally use Vivaldi as my main browser. This issue just started now. Last week when I installed Zorin OS 17.1 I did not realize any problems. I tried the Brave browser and there I have the same problems.

Interestingly, there are no problems with the Firefox browser. So I think it is a problem of Chromium-based browsers.

I already checked for updates - but everything is updated. A restart didn't help either.

Any suggestions?

Do you have any Extensions or Add-Ins, particularly any you do not recognise. You can disable them and test.

2 Likes

I am also using 17.1 core and ungoogled Chromium. But I have not had any problems with my wifi connection dropping. What hardware does your PC use to connect to the internet? What brand and whether it is wifi or LAN might help some of the gurus here give you some advice.

But I was wondering: if it's an issue with the Wifi or LAN connection why does it happen only on Chromium browsers? My Firefox works fine.

Let me check today. I've some add-ons. But maybe I can also test a clean install of Chromium browser to see if the error occurs as well.

not a suggestion ,just a mention ...i use brave too and don't have any problem with network dropping
17.1 lite

I wasn't suggesting that your wifi or LAN was the problem. But if you want help, the gurus need more information. How you connect to the internet MAY give them a clue as to why certain versions of browsers are giving you problems. I don't know enough about how browsers connect to the internet to really help you. But there are people on this forum that know a lot more than I do about these things.

Interesting.I am on Chromium and just went to 17.1 a couple weeks back when it came out and have had no problems with my Chromium at all.

Been running Brave on 17.1 Pro since I installed Pro with no problems ...... suggest you try zab's suggestion or maybe something else ...... Chromium Browsers don't appear to be a problem ....

Gday @tanair ,
Try disabling "hardware Accelerator" in the effected browsers,
As @zabadabadoo, said remove any extensions & test, I would also clean/clear cookies & cache in the effected browsers after any removal, Even try resetting the browser.

You may need to remove the effected browsers & install them again, (I would suggest one at a time & test as you go).
You may find disabling "Hardware Accelerator" in your BIOS if available, may help. (If you have BIOS "Hardware Accel", & can disable it, then you may not need to disable the browser accelerators).

Remember: Restarting your pc after a new install & then run the "Software & Updates" app.
Is good practice, but not always convenient.

As @citfta, said, we may need more info is correct :+1: .

If you still have issue's, please tell us about the installation of Zorin OS 17.1..

Was this a new/clean install of Zorin or did you Update from Zorin OS 17 or Upgrade from Zorin OS 16.3?

What was the program used to create the bootable device (USB Stick/DVD/SD Card etc)?

If it's a clean install of Zorin OS 17.1, did you run the check of the integrity of the download? Double check "Here"

Is this dual boot?

You may also check for BIOS firmware updates.

Hope this helps.

1 Like

Hi Ocka,
I first thought that the issue solved itself since it didn't happen again. But after a while the issue came back.
To be sure that this is not just a Vivaldi or Brave issue I freshly installed the Chromium browser from the Software Center. No Add-ons installed. But the issue also happens in the Chromium browser.

Only Firefox works without any problems. For testing I installed Librewolf, so a Firefox fork. It also works without any problems.

I installed Zorin OS 17 freshly. Before that I had Ubuntu on my laptop so I deinstalled Ubuntu and installed Zorin OS 17 Pro (using the Zorin installer). I still use Dual Boot so Windows 11 is also installed on my laptop.

I used a bootable USB Stick for the installation with the program balenaEtcher.
I did not skip any integrity checks during the installation. Unfortunately, I've formatted the USB Stick again after the successful installation, so I cannot run an integrity check for the file.

Edit: regarding this hardware accelereator I turned it off for Vivaldi but still face the same issue.

I have googled a bit and found this: Chrome Browser Keeps Detecting Network Change in Linux? Here's How to Fix it

But I'm not sure if I should really disable ipv6.

1 Like

I believe you can as I always disable IPv6 even in my VPN ..... been doing it for the past 6 years and haven't noticed any changes .... but as they say "up to you"

1 Like