Network stuck

Hi all guys
i'm a new fan of Zorin 16.2 Core
I installed Zorin on several my computers and one of these, an Asus F512F (Vivobook), yesterday suddenly started to show a question mark over network connection icon, in the right low corner.

By Terminal i found that ip address was correct and i can ping local and public addresses, like google.com or 1.1.1.1. Dns work correctly.

Wifi or cable (with usb adapter) don't change behaviour. Still ping every ip, ipv6 or ipv4, but question mark present and all network applications (email, nextcloud, firefox) aren't able to connect to internet. Is still possible to connect to internal router using ipv4 address.

I tried to remove ipv6 and alternate network usb adapter with wifi with no results. Tried an older kernel too without success. Starting with Zorin advanced option in grub and landing in text console give better result, 'cos i was able to surf internet with elinks.

Any help will be welcome.
Thank you guys

Andrea (from Pisa, Italy)

I sometimes see question mark on my wifi icon, but wifi contunues to function correctly.
Does your network connection suffer in any way when you see the question mark on the taskbar icon?

Maybe also have a look at this thread: Losing network connection
It relates to a Z15.3 problem, but that should not matter.

Thank you zabadabadoo. My network connection doens't work for any network app such as Nextcloud, Firefox, Evolution. Question mark present.

I have edited my post to include a link that may be of use.

Thank you, i'm reading it

Also found this: Networking on Ubuntu 20.04 - Ask Ubuntu

Ok, no userful command or workaround found.

I tried to use smartphone's hot spot without results. IP address via DHCP assigned correctly, routing table correct, ping to several server via ip or dns name works fine, but all network application are stuck. SSH to servers too.

If you have a LIve USB, boot that and see if you have Network in "Try Zorin"

The last link talk about a guy whose routing table was blank. Mine is correct and updated when i change wifi network.

Good, i try now, thank you

Did you try this from last link:

sudo apt-get install gnome-control-center

Cannot try because apt unable to connect to internet
Windows work fine from the second partition

Update, Zorin from USB stick in try mode works well.

Update:
i'm writing from Macbook Pro middle 2014 running Zorin OS 16.2 core, same home network of ASUS Vivobook F512F

Vivobook with Zorin OS 16.2 that works well for about a week yesterday stops working with network applications such as Netxcloud, SSH, Evolution, Firefox, APT.

Network interfaces obtain correctly DHCP address, DNS and routing tables, wired or wifi make no difference.

From Terminal i'm able to ping everything reachable such as google.it or 1.1.1.1, but network apps doesn't connect.

Starting a previous kernel unuseful.
Using Vivobook with Win11 on separate partition work fine, starting Vivobook with usb stick and "Try Zorin" works fine.

Starting Zorin from grub with "Advanced options" works. So i tried to run "dpkg" to repair damnaged packages and to run "apt upgrade -y". But after reboot no results obtained, question mark issue still here.

Thank you

Hi all, issue found. I installed a couple days ago a wonderful package called "Portmaster", showing in real time network connections such as Netlimiter in Windows.
Wonderful but not completely compatible with Zorin, because when removed the question marks was gone away.

1 Like

Sorry I have been out. Read through your posts and glad it was just a case of a installed app that caused all the problems.
I keep a written log of all updates and installs, so when something goes wrong I can look in my book to see what may have led up to it. Learning from experience.

1 Like

Thank you for your support Zabadabadoo

Great idea Zab ..... I take a screenshot of all my Zorin updates and keep them in a folder so I can also check back later if something gets messed up ..... I don't really download any other apps but taking a page from your book I'll start taking a screen shot of them too so I don't forget what I downloaded .... :+1:

1 Like