New 16.3 install - No Wi-Fi Adapter Found


New to Zorin. Just installed 16.3 on my desktop and so far everything, except wifi is working well! I'm currently using a cable but sometimes I move the computer and need wireless.

In settings, I am just getting "No Wi-Fi Adapter Found".

I tried following the directions on this page but nothing about wifi is listed under "Additional Drivers", only Nvidia stuff.

Wifi works on Windows. My motherboard is an ASUS ROG STRIX B550-I GAMING.

Thanks in advance!

This implies you need sudo apt install rtl8821ce-dkms run in terminal, but we can check forst.
In terminal run

sudo lshw -C network

and please relay the results here to this thread.

Thanks for the quick reply:

       description: Network controller
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:34 memory:fc400000-fc403fff
       description: Ethernet interface
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: enp6s0
       version: 02
       serial: 3c:7c:3f:d7:9f:55
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igc driverversion=5.15.0-78-generic duplex=full firmware=1045:740 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:37 memory:fc200000-fc2fffff memory:fc300000-fc303fff

Are you dual booting with Windows?

@Aravisian Yes. Got windows on another ssd.

On another card... hmmm... Well, go ahead boot windows and disable Fast Boot from the Power Options in Windows.
This may also mean you have Secure Boot enabled in BIOS Settings. Please check if so and disable it.
Then boot Zorin OS and test wifi.
Fast Boot and Secure Boot can both interfere with WiFi 6 AX200.

This is to see if they are interfering with it in your case.

It shows the driver configured and loaded.

1 Like

Disabling fast boot in windows worked, thanks! Secure boot was already turned off. How can Windows interfere like this if it's not even booted?


Windows Fast Boot does not fully shut off and shut down Windows. It behaves more like Hibernation, keeping it slightly active and it also places a lock on the drive in order to prevent Read / Write access since that could cause problems with the system actively in hibernation.
Because of this, Windows OS can still be locked in communication with Hardware Components even though you thought it was off - Since it is actually not off.

Being hibernated, it can appear to boot faster since it is not running full initialization, but instead just Resuming where it left off.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.