New battery not recognized

I just installed a new battery in my Lenovo Ideapad 110 laptop after the original battery stayed at 0 percent charge. The new battery, however, is not detected by my Zorin 0S at all and nothing shows in power management other than the AC power. Is there something I need to do to detect the new one? I don't think I connected it wrong.

Sometimes, it can take a couple of Hard Reboots.

I would try that first, make sure the notebook is fully shutdown and let it sit for a little while before booting back up.

Otherwise, you may need to try a kernel parameter like noacpi .

1 Like

I've powered it fully off a couple of times and let it sit overnight. Is that enough to gauge whether it worked? Also, how do I enable noacipi?

I would like to ask, if you're only running ZorinOS?
If not, perhaps you can check first if the battery is recognized with the OS.

Yes, I used to have a dual boot with Windows 10 and Ubuntu, but I swapped it out for Zorin 16. I guess I shouldn't have done that before switching the battery.

No problem there, I guess it's only the battery's indication that's "missing" right now, because the installation went ok and you have no further problems with installation/OS.

I had already installed Zorin first, before the battery replacement. But the battery isn't recognized when I run the OS, and if I unplug the AC power, the laptop powers off as if there were no battery.

Understood, it's not just the indication. Let's wait out for Aravisian's suggestion,

because I'm not that well known with kernel parameters.

As I am sure some of you know, you can choose to either buy the OEM battery for your notebook, or, you can buy an aftermarket battery. Buying aftermarket can be hit or miss in my experience.

It would be interesting to know, which version of OP's battery replacement, did they actually get? OEM? Aftermarket?

So where am I going with this you ask? Well, its indeed possible that an aftermarket version may not include a battery sensor. :scream: I know horrifying, like a ham sandwitch that is missing the ham.

It would indeed explain why his previous battery was seen, and the new battery is not. If the battery is still within the 30-day store return policy, I would return it for a replacement. If the store has a policy of no return after installation, then use the manufacturers warranty, which its no doubt still under warranty!


Interesting. I didn't think of that. Thanks for the suggestion.

I will hold off on replying, then, until the Battery question is answered.

1 Like

But should I try your solution first, before I am sure the product doesn't work right?

Is your battery an aftermarket battery?


It's an off brand, yes.

I think this should be the primary focus rather than risking a kernel parameter on a battery.

1 Like

I recommend returning the battery if you can. Since its an aftermarket battery, it could most certainly be indeed the case, that the battery doesn't include, a battery sensor. And this is the core of your issues here.

Recommend proper OEM replacement in the end. That should get you good to go.

1 Like


I had a bad experience with an after market Mac battery. I had to return 2 times since it even did not charge properly. 3rd one was OK.

We had no choice since the parts were no longer supplied by Apple for such old MacBooks.


Thiss could be a popular. Did you have any warranty billing buying from aftermarket? The chip on battery could be a broken.
"Problem: Battery not detected error. Contact technical support"

upower -i /org/freedesktop/UPower/devices/battery_BAT0

native-path: BAT0
vendor: Lenovo IdeaPad
serial: BAT20101001
power supply: yes
updated: wto, 20 lis 2018, 22:41:23 (64 seconds ago)
has history: yes
has statistics: yes
present: yes
rechargeable: yes
state: charging
warning-level: none
energy: 16,64 Wh
energy-empty: 0 Wh
energy-full: 27,78 Wh
energy-full-design: 28,52 Wh
energy-rate: 15,644 W
voltage: 14,682 V
time to full: 42,7 minutes
percentage: 59%
capacity: 97,4053%
icon-name: 'battery-good-charging-symbolic'
Outdated battery drivers - The operating system loses compatibility with the battery due to outdated drivers - so just update them.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.