"New File" gone from right click menu

"New File" gone from right click menu.
i hid the Template folder in /Home after i installed by renaming it with a . before the name like this ".Templates".

I then after some time realized that folder was important so i restored the name back to "Templates" like other people said i needed. after multiple reboots the "new file" option is still gone from both the desktop and file explorer right click menu. I have templates inside of the folder so that isnt the problem either.

how do i fix this? I really dont feel like reinstalling again...

1 Like

Hi and welcome to the forum :slight_smile:

First, Yyou could try uninstall and reinstall Nautilus:

sudo apt-get --reinstall install nautilus

1 Like

Thanks :slight_smile:
That didnt help even after a reboot.

isnt there like any config that needs to point to the right folder or something that i can check?

Beyond that I have no idea.
I will ask @Aravisian, he knows Gnome desktop better than myself.

You might have already noticed, but those folders under Home with special icon should not be deleted even you do not need them. They are integral part of Nautilus.

1 Like

thank you.

yeah i havent touched the hidden folders. only the template folder which i thought had no use. this is my first linux version coming from windows 10.

Welcome to the Linux world.
We all learn from our mistakes (TM) :wink:

Ironically, some (not all) of the hidden items can be safely deleted.

1 Like

A failing with Nautilus, really...

You might try this technique (17.04 but should still work):


Ive already tested that...
but in the comments i found the fix.

" You have to tell the system where your template directory is first:
gedit ~/.config/user-dirs.dirs"

thanks for the help guys :slight_smile:

any way to make it show on the desktop to and not only in the file explorer?


Are you talking about Home folder?
Zorin Appearance -> Desktop -> Show Desktop Icons

no, the "New Document" tab only shows on the menu if you right click in the "Files" app.

here what i meant:

On my Zorin16, when I right click on the desktop, the first 2 options in the drop down list are: New folder and New documents

If you do not have them, then you still have a broken file manager I am afraid.

Might this help?

It seems GNOME developers stripped this function from Nautilus and Zorin restored it. I think you have to re-do this addition yourself.

ive only partially restored it then. it still dosnt appear on the desktop...
but it works in folders.

ill search google with this new information...thx

EDIT: Apparently it only took a while for the desktop to register the changes and update... its working everywhere now! :wink:


Nautilus-desktop probably needed to reload. In future, you can launch manually with alt+F2, then enter in nautilus-desktop


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.