New install - black screen - dual boot Windows 10

Hi all - I am completely new to Linux, and wanted to try using Zorin OS as a dual boot with Windows 10. I have an HP Spectre x360 (2018, with 8th gen core i5, 8GB RAM, 256GB SSD).

I managed to shrink the Windows C drive by 30GB to give room for an install (using the instructions here), and followed the instructions here to create a bootable USB drive. I managed to boot to this (disabling secure boot in BIOS), and used the "try" option. This booted fine from USB, I enjoyed the desktop experience, and so proceeded to do an install of Zorin OS Core, just using the default settings from the wizard (as I don't know anything about different partitions and sizes). This all seemed to be successful.

However, after I then restarted my PC, I have so far been unable to boot to Zorin OS at all. In the bootloader, if I select "Zorin OS", it just loads a black screen. If I use recovery mode, it shows the two lines "Loading linux 5.11.0-38 generic..." and "Loading initial ramdisk...", and then just hangs. Secure boot is still disabled in BIOS, and fast start-up is disabled in Windows.

Selecting the Windows bootloader does work, and I can still boot into Windows 10.

I would be very grateful for any suggestions - as I say, I am completely new to this, so your patience is appreciated!

Hi and welcome to the forum :slight_smile:
I think your machine has NVidia card and might need to edit grub.
For example:

1 Like

Hi, and thanks for replying so quickly! As far as I am aware, my laptop only has integrated Intel graphics, and no Nvidia graphics. I have tried editing the Grub parameter to include "nomodeset" after and before "quiet splash", and in each case it still just went through to the black screen.


My guess was wrong :frowning:
I think we have to escalate the case to the volunteers who are more familiar with graphics card related issues.
@StarTreker do you have any idea?

1 Like

Since I guessed it wrong those editings would not do anything :sweat_smile: Sorry about that .

1 Like


I assume that you can boot off of the USB installer you used to install Zorin OS correct? If so, thats good new, because I want you to boot off the USB drive please.

Once in the system, click the left option to Try Zorin OS.

Then I want you to click on the Zorin :zorin: logo bottom of screen. Please type Gparted. Launch Gparted please.

Now is when I want you to take a screenshot please, press PRINT SCREEN key on your keyboard.

A screenshot is the only way for us to get visual proof on what you have done with your partitions, we need to see this in order to help you.

I would also like to see some system info as well. CTRL ALT T to enter terminal please, and enter this command.


Please posts the results of that here as well. It might not hurt to get a screenfetch while you are there as well.

sudo apt install screenfetch

Once installed, then just type screenfetch and as before with the other, please posts the results here.



Seems right. Looks like only the i7 version of x360 has Nvidia graphics according to this:

1 Like

That is a bit small... I suppose just for testing it is fine.

1 Like

Hi - thanks for this reply. I have managed to boot again from USB (currently in Zorin OS booted from USB as I post this).

Gparted screenshot:

lspci screenshot:

Unfortunately I was unable to install screenfetch - it failed with the error "Unable to locate package screenfetch"; I don't know if this is a result of me running this off the USB.

1 Like

You must update the sources, first:

sudo apt update && sudo apt install screenfetch

Looking over the lspci, I do not see anything that should have conflicts. Did you get any errors during the Zorin OS installation?
You may try booting Zorin OS in verbose mode and reading the output on the screen looking for any failure lines or error lines.
You can do this at normal boot by tapping the esc key at the Motherboard splash screen. At the grub menu, tap the e key to edit.
Remove the quiet splash entry, then when done, exit the editor and proceed to normal boot.

Hi, thanks for the speedy reply.

Screenfetch screenshot:

I did not get any errors during the Zorin OS installation.

I will try booting in verbose mode as you suggest.


I went into grub, deleted the words "quiet splash" and booted. Unfortunately, the only difference is the words "Booting a command list" at the top, followed as before with the lines "Loading Linux 5.11.0-38 generic..." and "Loading initial ramdisk...", with nothing else. No error of failure lines.

1 Like

Have you tried tapping the esc key at the grub menu, entering Recovery Mode and selecting a different kernel?

The Grub menu appears on every boot up (I don't have to press esc to get there). Under "Advanced options" I can select the recovery mode option, but this does not do anything different than the other option (same two lines show up as before). There is no option to select a different kernel, as far as I can tell.

sudo apt install linux-headers-5.11.0-27-generic linux-modules-5.11.0-27-generic linux-modules-extra-5.11.0-27-generic linux-image-5.11.0-27-generic

Hi - apologies again for my ignorance, and thank you for your patience. Where should I run this command? The minimal CLI which I can get to by pressing esc in Grub?

From the Advanced Options for Zorin, open the recovery Menu,
Arrow key down to "enable networking".
Once enabled, back up the the Recovery Menu
Arrow key down to "drop to prompt"
Then hit enter
Then put the command in. Too bad you cannot copy and paste it, so be exact with the typing...

Under "Advanced options for Zorin", my only two options are "Zorin, with Linux 5.11.0-38-generic" and "Zorin, with Linux 5.11.0-38-generic (recovery mode)". Neither of these two options brings up the recovery menu which you have described.

Hi - following those instructions, selecting the option ending (recovery mode) for me does not take me to another menu, as that article suggests that it should. Instead, it takes me to the same black screen with two lines as before. Given that: (i) the live USB boots absolutely fine; and (ii) I have never been able to boot into Zorin from disk (and even this recovery option does not work), does this mean that either Grub or the Zorin installation is defective? If so, is this something I can fix from the live USB (e.g., can I re-install from the live USB)? Any thought/solutions welcome, and thank you again for your time and patience.