New install crashed now won't reboot

Hi new Zorin/Linux user here, I recently installed Zorin Lite on my 5 year old Dell Inspiron netbook(64bit, 30Gb SSD 2 GB RAM) because the computer struggled to run with Windows 10 using the vast majority of the drive space.

I followed the instructions on the Zorin website to make a USB boot drive, checked for errors before installing it and installed the OS.

After a few hours of running fine, while using qbittorrent the computer froze. After waiting a few minutes I forced a shutdown and tried to reboot the system.

I saw the Zorin screen then the Dell symbol came up then it started repeatedly flashing the Dell screen and nothing else.

I tried rebooting with the USB boot drive plugged in but nothing happened.

Does anyone have any advice? Have I bricked my computer?

Check that you have boot priority for the USB in your BIOS.

If you are able to boot the computer up at some point, I would strongly recommend you run an anti virus scan using ClamAV or some other Linux based anti virus equivillent.

Many years ago, I tried the torrent downloading scene, and what I got for my trouble, were virus’s, the worst of which, was a boot sector virus that destroyed my hard drive. Of course, that was when i was using Windows.

Hope you can get this fixed.

1 Like

No. Don’t worry.

Since it is crashing right at the Boot Splash, this suggests a graphics conflict during boot. You have several options available for how to access your default grub file.
Option 1.) Boot as normal but hold down the Left Shift key during boot up to pull up the Grub Menu. Once you see the menu
zorin-boot-grub-menu

hit the ‘e’ key. This will open the Editor mode for grub.
This screen should look like:
zorin-set-params

You see the line that says

linux /boot/vmlinuz-2…496a ro quiet splash

Use your arrow keys to navigate the cursor to the end of “splash” on that line and add “nomodeset”.
So it should then look like

linux /boot/vmlinuz-2…496a ro quiet splash nomodeset

Once done and no typos made:
Hit ctrl+x to start the boot process. You MAY need to try rebooting a couple times. If this does not work, please report your findings.

1 Like

Thank you for your advice, your first method of accessing the grub file didn’t work, could you please list another way to get to that screen?

If holding Shift didn’t work, can you try tapping Esc repeatedly?

2 Likes

Esc worked but on the line

mine ends in quiet splash $vt_handoff

Should I delete the $vt_handoff and replace it with nomodeset ?

That is odd. Yes, go ahead and replace it. You can change it back if needed.

I replaced $vt_handoff with nomodeset and pressed ctrl x see the Zorin screen then get a black screen with a flashing dash in the top right of the screen and nothing else.

Ok… Let’s repeat the process slightly, but then take a different path.

This is if there are broken Packages causing the problem:

Hold Left shift key during boot- when you get to the menu, select Advanced Options
Then Recovery…
This will bring up a recovery menu.
From there, tab down to the Networking option and follow that to enable networking. Back out to the Recovery Menu, tab down to Drop to Prompt and select that.
Hit ctrl+d or Enter to start the prompt.

In the prompt enter

dpkg --configure -a

sudo apt remove --purge lightdm

sudo apt install lightdm -y

Follow the Prompts, then

sudo apt remove --purge gdm3

If this fails

This is for Boot Repair:

You may need to repair Grub. Follow this tutorial here to repair grub, then reboot the computer to ensure that it worked:

1 Like

Thank you again for all your help.

So I followed the instructions for broken packages and it brings me to a login screen that doesn’t accept anything in the password prompt.

I’ll try the grub repair next.

1 Like

That is not something I expected at all… Lightdm is working, you see your normal login screen after the Zorin Logo and it does not accept your password?

Grub should be fine and not in need f repair if the blinking cursor is gone and you were able to boot to Lightdm.

1 Like

The login screen I see is black and says Zorin OS 15.3 (name of my computer) ttyl
(Name of my computer) login:
No matter what I put in the login and hit enter I can’t type anything when "Password: " appears.
Edit: ok I had to put in the password without anything showing up on screen.

So next it tells me I can upgrade 8 packages and to run apt list --upgradable, also I get a line saying -bash: cannot create tempfile for here-document: No space left on device.
After I run the upgradable list I’m not sure what to do next

Incase there is any confusion when entering the password, I wanted to speak on my experience. If I am in Zorin OS, and I switch to terminal mode, it will ask me for my credentials for security reasons. When I enter my password, terminal gives me no visual feedback, but my password is being entered. And as long as I don’t misstype it, after entering, it accepts the password. Might be the same thing happening for you.

1 Like

Thanks that helped.

This printout usually appears if you are operating from the LiveCD, not from Zorin OS installed on the HDD.

You can run

sudo apt upgrade

But- I want to hold off on further steps until you verify your install and ensure there is no bootable media in any drive.

1 Like

Ok I ran the

I made sure not to have any other media (USB or SD card) plugged in before doing any of this.
After running the upgrade the message I get is
“E: You don’t have enough free space in /var/cache/apt/archives/.”

Then just the terminal prompt.

Thanks for all your help today, I think I’m going to take a break from this and start again tomorrow.

Carmar spotted this, which I failed to notice, from the O.P.:

Sadly, that is probably not enough.
Even so, in running everything, your computer crashed… Which upon checking, we are getting an error twice

-bash: cannot create tempfile for here-document: No space left on device.

E: You don’t have enough free space in /var/cache/apt/archives/

Thanks Carmar for spotting what I missed and shame on me (My brain read 300Gigs)…
I think that it is clear that your drive is not large enough, even for Zorin OS.

1 Like

Back in the Zorin OS 9 and 12 days, you could get away with 16GB to 30GB. But I think you really need 60GB for OS 15. You can get a 128GB drive for less then 50 bucks these days so ya.

1 Like

Aravisian, you’re still nowhere near my level of misreading posts. :wink: