New install on Lenovo m73 freezes on boot

Hardware is a Lenovo ThinkCenter m73 tiny with A 1tb drive. Detailed specifications for ThinkCentre M73 (Tiny Form Factor) - Lenovo Support CA

Originally running a single partition with Windows 11
Booted ventoy disk, installing secure boot certificate when prompted, booted the Gparted live d iso from ventoy
Used parted to shrink volume, create new NTFS one at end of disk
opened command line in the parted os and used mv to transfer a media folder to the new partition. Rebooted because disk was locked by booting ventoy then booting parted live. Then shrunk windows partition to 100gib, leaving 100gib of free space between the windows partition and the media partition

Booted ventoy to boot the zorin os 16 core live cd.
Chose the "install with windows option" and zorin os automatically chose the 100gib of free space to use as boot drive.

Enabled third party drivers and set a password needed for the drivers. Set up an account and password. Finished install

Removed USB drive when prompted and rebooted, got a secure boot certificate screen and clicked past it, then got the Zorin OS installed boot menu and chose Zorin OS from the menu

Zorin OS froze with the Lenovo logo and hexagon Z on the screen.

Forced reboot and disabled secure boot in settings. Zorin OS froze again

Forced reboot and booted windows. Windows runs fine.

Rebooted and run Zorin OS with the older kernel and safe mode. Boot keeps hanging at "[ok] Reached target Local Encrypted Volumes"

I can't seem to get past this. I did get another line to show up about not finding drivers for the USB Bluetooth device (which wasn't present during install) but I unplugged it and no change.
What troubleshooting steps should I take next? Thank you.

You had not checked the box for encrypt drive with LUKS correct?

This is an odd one...
Are you able to reach the Advanced Options for Zorin option in Grub Menu?

I'm pretty sure I can, what should I do in there?
I tried "zorin, with Linux 5.15.0-56-generic (recovery mode)" and "... 0-73-generic recovery mode" and that's where I end up as pictured

Choose Recovery menu
Then arrow key down to the bottom and drop to prompt.
In the terminal prompt, run

sudo nano /etc/default/grub

This will open your grub file in a Terminal Text Editor. You will need to arrow key to navigate.
Add the line GRUB_TERMINAL=console beneath the GRUB_CMDLINE_LINUX=""
It should then look like:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

Once finished, tap ctrl+o to overwrite (that is the "oh" key not the "zero" key), then enter to save current config, then ctrl+x to exit the text editor.
Now, you must run

sudo update-grub

Once that is finished, try booting up...

One more thing...
In your BIOS Settings, ensure that CSM is enabled

Is this the screen you mean? I can drop to grub> by pressing c but it can't find the sudo or nano commands.

Turning on csm does let me boot Zorin OS in recovery mode. Do I need to keep csm enabled for zorin or can I fix the efi booting?

Keep CSM enabled, throughout.

Is that screen photo from the baremetal install or the Live USB?
You installed Zorin, so the USB should be unplugged, now...

I am not sure what you mean by this...

I'm currently booted the Zorin OS actual, installed on the hard drive with the USB drive removed. It's currently past midnight, but since I'm now in the os and know how to get there I should be able to find fixes

Ok, in the screen photo, you have Recovery Mode highlighted. Hit enter on that highlighted option.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.