New Monitor 32" 4K - Stuck at 1024p

Looking at your poast again I see you ran the driver auto install, but i don't see mention apt update and apt upgrade - can you run
sudo apt update
sudo apt upgrade

the latest amd drivers are in the kernel modules and may not update if you do not have the latest kernel for your hardware.

1 Like

I have just done it, no changes :cry:

I won't have time in the next few weeks to save everything and reinstall, I contacted Gigabyte for now, to see what they respond

Good luck Sachy31. Come back and let us know what you find out?

I'll keep you posted!

Weirdest thing I've experienced in years, a monitor not recognized (although I'm new to Linux). Generally, monitors are pretty plug and play, even with Linux!

Still no response from Gigabyte...

Holy spider webs!

Have you had any change with your system otherwise?

I went back to my previous screen and it works at 2560x1440... I don't know what's wrong with the other screen...

~$ xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 2560 x 1440, current 2560 x 1440, maximum 2560 x 1440
default connected primary 2560x1440+0+0 (0x522) normal (normal) 0mm x 0mm
	Identifier: 0x521
	Timestamp:  27423
	Subpixel:   unknown
	CRTC:       0
	CRTCs:      0
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	non-desktop: 0 
		supported: 0, 1
  2560x1440 (0x522) 342.835MHz *current
        h: width  2560 start    0 end    0 total 2560 skew    0 clock 133.92KHz
        v: height 1440 start    0 end    0 total 1440           clock  93.00Hz

No changes... Still stuck no responses from Gigabyte. Back to the previous monitor.

I still don't understand whether it's the gpu, the screen, or the os

Do you have xserver-xorg-video-ati installed?
If you have it installed, try switching to it.
Then in terminal, run:

sudo update-initramfs -u

Reboot and check what resolutions are available.

1 Like

Will try :blush:

Here is the response from Gigabyte...

*Dear Customer, *

If the monitor is able to be picked up by other devices and works properly, this points to a Linux Issue. we don't have drivers for Linux unfortunately.

*Best Regards, *

Gigabyte Tech Support

Have you made certain that Secure Boot is disabled in BIOS Settings?

This is making me nuts and its not even my monitor. lol
Sachy31? Have you tried changing modes on the monitor itself? Sorry everyone, I'm kind of reaching at this point.


Hello! Yes I have tried changing modes on the monitor itself

Yes it is disabled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.