New Monitor 32" 4K - Stuck at 1024p

Hello - Newbie here!

I first installed Zorin OS a month ago, back then using a monitor Aorus 2k. Right after installing the OS, the monitor worked at 2k with no issues.

I just installed a 32" 4k monitor, and for some reason the resolution is stuck at 1024 and I can't change to another resolution.

I am using the IGP of a Ryzen 7600 (HDMI connection). The Monitor is an Aorus 32" 4k. It is likely an issue of drivers but I can't find Linux drivers from the manufacturer.

I have done this, which did not change anything:
sudo apt install ubuntu-restricted-extras
sudo ubuntu-drivers autoinstall
Then reboot
After restart I ran this command (sudo lshw -C display):

*-display UNCLAIMED
description: VGA compatible controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:0f:00.0
version: c6
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: latency=0
resources: iomemory:fc0-fbf iomemory:fc0-fbf memory:fce0000000-fcefffffff memory:fcf0000000-fcf01fffff ioport:e000(size=256) memory:fc900000-fc97ffff

That's rather generic and doesn't tell what AMD card you have. Try see if inxi can see it.

sudo apt install inxi
inxi -G

Thanks for helping :slight_smile:

Here you go:

  Device-1: AMD driver: N/A 
  Display: x11 server: X.Org 1.20.13 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa resolution: 1024x768~76Hz 
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.2.6


cat ~/.config/monitors.xml
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00* 
cat: /home/Adrien/.config/monitors.xml: No such file or directory

It's weird, in this menu I just can't change the resolution since I connected the new monitor...

Screenshot from 2023-05-06 07-13-02

It seems your scrren isn't identified. Try see if the live USB pick up the screen.

try using xrandr to set the screen size that you want.
xrandr --verbose

to see what sizes are available.

after, use xrandr -s 8, in my case, gave me the screen resolution of
2048 x 1152
I believe the number after the -s, corresponds to the screen size and refresh rate. I don't know how to specifically narrow it down as to which. :slight_smile:

Oh, also you can just use:
xrandr -s 1920x1080 to get that resolution.


Will try!

Will that revert to the previous resolution when I reboot?

Sorry I'm not sure what you mean?

Is there something I can do so the screen is identified? I have to say I've used several monitors with this build, and it's the first time I'm experiencing this issue of a monitor not being detected.

Here is what I get :cry:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 (0x523) normal (normal) 0mm x 0mm
	Identifier: 0x522
	Timestamp:  63347
	Subpixel:   unknown
	CRTC:       0
	CRTCs:      0
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	non-desktop: 0 
		supported: 0, 1
  1024x768 (0x523) 59.769MHz *current
        h: width  1024 start    0 end    0 total 1024 skew    0 clock  58.37KHz
        v: height  768 start    0 end    0 total  768           clock  76.00Hz

Here is what I get:

xrandr -s 3840x2160
Size 3840x2160 not found in available modes

If that helps, here is the model of the monitor:

Everything I've read so far suggests you should have no issues getting the screen resolutions beyond that. But, I wonder if its a case of the newness of the processors vs your current kernel? Ideas anyone? Also, would the HDMI cable matter at all?

1 Like

Are you using hdmi or DP, because i couldn't get my gigabyte monitor above 1024x768@59hz , on hdmi on the 5700g over hdmi - but 1080p @ 165hz worked on DP. (hdmi/DP didn't seem to matter to the 580x though)

Also with hdmi - cables are important as there are 1.0 1.1 1.2 2.0 ect hdmi cables and even directional cables and they will affect features performance and functionality.

1 Like

I am using an HDMI cable, the same that was working with this computer and the other Gigabyte 2k Monitor that was set at the maximum resolution @ 144hz... I tried another HDMI 2.1 cable and it didn't change anything.

That is what I was thinking... Would it worth contacting Gigabyte's support team? The screen is really not recognized and is pretty new in the market. Is there a way to setup drivers or similar?

The previous one that I was using had been released in 2018 and was recognized by Zorin OS

I'd say not a bad call persey. But, before that, would you be able to install a different OS or 2 or 3, :slight_smile: , and see how they handle the combination of that iGPU and display? Time and resources permitting. Just make sure you save your data somewhere safe before you start. If not, yeah contact Gigabyte AND AMD. See what kind of info you can fish up.