New to install - cursor frozen

Hi - I’m new to Linux and walked through installing Zorin via a USB.

While it was booting from the USB, it seemed slow, so I (impatiently :-() tried exiting, and typed some characters during the process. After a short time the desktop appeared, but the cursor is frozen in the middle of the screen.

I’ve tried restarting the machine (HP pavillion laptop) and even removed the USB stick, but it’s stuck on the Zorin desktop image.

Thank you for any input or advice.

From the OP, it sounds as though the OS was not installed, but was being run on the USB as “Try Zorin.” Have I understood this correctly? You did not fully install Zorin?

That is correct.


In that case, I would just wipe and rewrite the bootable medium, then boot it up and test it.

Thanks - I’ll do that.
Initially I couldn’t escape from the frozen window, even after rebooting. But after leaving the machine off for a couple days, I was able to open it to W10.
Hopefully I’ll get it right this next time. :wink:

Same problem. I can tab and F1 brings up the start menu, but the cursor does not move.

Is this a UEFI machine?
Does it currently have Windows 7 up to 10 installed?
Is secure boot enabled in the UEFI?
Is Windows set to Fast Boot?

Windows Fast Boot locks the drive, preventing access to it. It must be turned off to access the drive on another OS - However… I must be clear on this: I am not really sure if that would apply to Try Zorin on a USB or not. If it is, this would be the first I heard of it.
But that certainly is Not evidence that it doesn’t. So, it is worth disabling Fast Boot and seeing if that resolves.
Secure Boot- is very similar to above, except I have doubt that it would inhibit the USB Try Zorin. But it is possible… Datburned newfangled Windows additions…

Otherwise, whether or not Windows is currently installed on that computer- can you give the Specs on the HP Pavilion Notebook?

It sounds like the image you’re using doesn’t have the driver for your TouchPad/ mouse. If you’re using an external mouse (gaming or otherwise) unplug it until you actually install it, then you can download the drivers or upgrade the Linux firmware.

If it’s the TouchPad, and have internet access in the zorin image, open the terminal (ctrl + alt + t).


sudo ubuntu-drivers autoinstall

Unless you made the image persistent, you will have to do this every time you use the usb image. The command above installs the latest drivers for your hardware in the firmware version zorin is using.

Brand new machine came loaded with Win10
HP Pavillion x360 convertible 14m-dw1xxx

BIOS mode is UEFI
Secure boot is on

It is the touchpad, and I can’t seem to get to the internet on the zorin image.

Secure Boot must be disabled in UEFI in order to operate (Or in most cases, install) Linux on another partition.
But USB- I am not sure on.
You might just go ahead and turn Secure Boot to disabled, then try booting up in your USB image and test it out.

Since this is a newer laptop I’ll take a stab in the dark here… go to this site

Under ubuntu, the groovy gorilla version, download the linux_firmware_1.190_all.deb file. Copy the file onto your machine in downloads directory.

Open your terminal (ctrl + alt + t) and change to that directory:

cd ~/Downloads

Under the assumption you haven’t put any other .deb files in this location type:

sudo dpkg -i *.deb

This will install that firmware. Very important now… REBOOT.

You should have internet access. Maybe you’re TouchPad works now to. Let us know.

If you’re doing this just to try it on usb, not installed, this fix won’t work because installing the drivers requires a reboot and unless it’s a persistent image, it won’t retain the update. If you go through and download this file you may as well install zorin on a little partition, install the firmware, then try it.

The next release will more than likely have driver support on usb, but we’re at the tween and must wait for the release of zorin 16 otherwise.

Thanks for your input. I decided to start fresh with a new set of instructions. I have been able to get Ubuntu working, internet access and keyboard/mouse working.
I did get a message indicating the install had 17 errors - but I haven’t found what those are yet or what they affect.
Looks like this particular issue is resolved - thanks!