New user, optical drive issues


I recently purchased a somewhat old Thinkpad to lug around, and my first plan was to go with Linux Mint, which I did, until I saw ExplainingComputers showcase Zorin OS 17. So, here I am, trying it out.

Unfortunately, the same problem I had with Linux Mint persists, which is the optical drive not working as it should.

What it can do is:
-read data from DVDs
-playback DVD video

What it can't do:
-play audio CDs
-recognise audio CDs

I was really hoping to rip my CD collection with this Thinkpad, but I can't get it working no matter what. VLC gives me this error when I try to play an audio CD:

Your input can't be opened. VLC is unable to open the MRL 'cdda:///dev/sr0'

When I open Disks, it says there is no media in the drive when an audio CD is inserted. The Thinkpad in question is a W700, and the optical drive is installed in the Ultrabay Enhanced slot. Now, I'm an absolute beginner, but while lsblk lists sr0, blkid doesn't. So, when I tried to mount the drive to a folder, terminal said "no medium found on /dev/sr0".

Any suggestions? Discs and lens are clean.

Did you installed the Codecs?

During the initial installation? Yes. Also, I installed the ubuntu-restricted-extras package via terminal. If there's something else I should install, please let me know.

To be sure, please look at Gnome Software Center and scroll down to the Codecs Entry:

Click on it and look if the Stuff is installed.

Then you could try ... Open the Terminal and type:

sudo apt install libdvd-pkg

And what I forgot at the Beginning: Welcome to the Forum!

OK, I installed everything. But audio CDs are still not recognised anywhere.

1 Like

Just out of curiosity, I dug out an old Vaio laptop and installed Zorin 17 on that one as well to see if it would mount and play audio CDs normally. And it did. So, the problem is with the Thinkpad's Ultrabay Enhanced drive compatibility.

1 Like

Oh, okay. The only Thing, what comes to my Mind was to try to install zorin-restricted-extras. But because You have already installed ubuntu-restricted-extras I doubt that this will work. But when it is a Problem with your Thinkpad ... I don't know. Sorry, that I can't help.

Maybe a more experienced User can help. So, (Mr. or Mrs.) @Aravisian! If You read this, You can give any Advice?

Mr. :wink:

I do not recommend VLC right off the bat.

VLC has a lot of troubles with codecs, in general.
@nimrod64, is your firewall (UFW) enabled?

CD Readers and DVD Readers are pretty different from each other in how they work. A DVD reader can read DVD's, CD's as well as RW mediums. CD readers, however, are much more limited in scope, solely able to read the basic format for a small volume recording.
A few years ago, this was fine.
But these days, many CD's rely on the same technology used in creating DVD's, which allows a larger volume of information to be stored by writing more information in the pits (I did not name them...)
Pits are where data is stored. In a CD, a Pit contains one data sum. In a DVD, a pit can contain many sets of data... and here you can see the problem.
A CD reader lacks the ability read and recognize multiple data sets in one pit.

I do not know if this relates to the issue you are experiencing but it may and if you are experiencing this same behavior across multiple distros, I would suspect the reader itself.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.