New Window Keeps Opening Behind Active One


I am experiencing this weird behavior where if I open a new window it always opens behind the active one. This is not specific to one program but all.

Is there a setting to disable this so that new windows show up on top of the active one rather than hidden behind? System details below from uname -a and neofetch

Linux JBlack 5.15.0-53-generic #59~20.04.1-Ubuntu SMP Thu Oct 20 15:10:22 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

OS: Zorin OS 16.2 x86_64 
Kernel: 5.15.0-53-generic 

As I recall, one of the things I dislike about Default Gnome is that new windows open Minimized.
I mean... I opened it for it to be open...

Anyway, are they opening and placed behind a window- or opening as Minimized to the panel?

Here is a screengrab of the issue, as you can see it doesn't open the window minimized, instead it opens the new window directly behind the one thats active, you can see it towards the right border of the active window when i click on "new window"

I checked if it was only chrome but its with all apps.

1 Like

And it does not matter which app is active?

There is a setting for App windows for "Always On Top". You can ensure that is Unchecked.

Here is the file manager, i right clicked to make sure it didn't have the "always on top" option selected, as you can see, the new window opened behind the active window. In this case the window is small/resized so it doesnt seem to be too annoying but when the windows are maximized (or nearly maximized) it becomes a problem.

Basically any window that allows a new one to be opened will open a new one behind it, not on top which is the behavior im used to.

Sorry about the blurry gifs btw .. haven't figured out how to make them sharp at giphy

It gets the job done.

I am at a loss...
Is this a fresh install of Zorin OS?

Installed it roughly 1.5 weeks ago, altho... I did install the forge extension to tile windows.. I haven't done any real customization to the stock theme.. not sure if that would cause something like this to happen?

You might

mv ~/.config ~/.config-bk

and reset all personal configurations to default. Reboot and test if it is still doing this. If it is, you can

mv ~/.config-bk ~/.config

to restore your previous settings.

Yup, something in my configurations created this situation... i wanna say it was the window tiling 3rd party app that said it "could" create instabilities and which I readily ignored (-_-)

Thank you so much for your help, im very grateful!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.