[Newbie] OpenAl locate/install issue (edited, library dependencies help)

Thanks.

I have the music files from the fan site, but I don't know where to put them so they play in-game. I ran the fan site suggested commands, but I still only get sound effects and no music in-game.

wget https://www.7kfans.com/downloads/7kaa-music-2.15.tar.bz2
bzip2 -cd 7kaa-music-2.15.tar.bz2 | tar xvf -
mv 7kaa-music/MUSIC data/MUSIC

The music files are where they're supposed to be, at least according to that command destination, but I'll have to test where to put them. I'll try to get it done later. If any information for that is in the link you left above, https://cdn.netbsd.org/pub/pkgsrc/current/pkgsrc/games/7kaa-music/README.html, I fail to see it, but I'll definitely take another look at that later.

Right now, I'm trying to create and place a shortcut for the game. I don't even know what file extension I should be looking for, nor file location. I'm searching for it online, but my OS doesn't seem to have certain directories, like:

/usr/local/share/applications

I have no such folder in that directory in Zorin and, as far as I know, I have activated the option to see hidden files and folders.

It's there.
You hit ctrl+h to see hidden files and directories? Hidden (when shown) files have a . in front of them. You should see /.config, /.cache, /.local and many others.

How are you launching the game? Whatever you are using to launch it, that is your 'Exec='
That path to it is your exec path.

1 Like

When I type /usr/local/share/applications, I get:

bash: /usr/local/share/applications: No such file or directory

When I go to that directory using the file manager, I also see no such Aplications folder, even with "Show hidden files" option activated. I pressed CTRL+H in there to see if it showed any difference, but it was the same, no change.

I got the music running. Turned out, I had to use this command from terminal, in game build directory sudo mv data/MUSIC /usr/local/share/7kaa/MUSIC.

I find it intriguing that I had to move the music from where I put it, which was the supposed correct location (similar to the correct Windows location) indicated in the game fan site, to such a new (strange?) location.

Also, is the path /usr/local/share and its sub-directories supposed to be system files/folders? Is this the same to all of us, in Zorin 16 version, or is there something wrong/broken in my system, perhaps something I may have done?

From what I can tell, this locations seems to be owned and accessible only to root Superuser. It took me 2 days to understand I actually can still place stuff there, albeit it has to be done through commands in terminal, using sudo prefix, and not by simply dragging files or using CTRL+C then CTRL+V, like I thought. Basically, I found that out just a while ago. :sweat_smile:

As for shortcuts, I'm following this tutorial https://www.howtogeek.com/445303/how-to-create-desktop-shortcuts-on-ubuntu/. Still no success, but tomorrow's another day. :sweat_smile:

The lack of knowing the file to launch is a set back. In terminal, I just type 7kaa in any directory and the game just launches. Even in root directory, with no files there, only folders, typing 7kaa and hiting ENTER still launches the game.

/home/$USER/.local/share/applications/ is the User directory

/usr/share/applications/ is the Root Directory

You can navigate in the Root Directory using your file manager by elevating to Root, then launching the File Manager:

sudo -i

nautilus

You might try using locate command:
If not already installed:

sudo apt install locate

locate 7kaa

Usually, installed exectuable files will be placed in /opt
They may be in /bin if they are a binary file
Or they may be in their own directory under /usr/share - you may look for /usr/share/7kaa

Lastly, you may check if a desktop file was created (I have my doubts as it being created would also place it in the app menu) but you can check /usr/share/applications and see if 7kaa is present there.

Thanks for letting me know some usual places for apps, installs and such in a linux system. I'll be able to look better for some stuff I was looking before and a few more needed commands to learn.

Unfortunately, 7kaa executable, nor its binary file, is in neither of those locations.

In /usr/share/applications/, I have a great number of .desktop files of installed apps., which I'll look into and try to mimick for creating a shortcut, but there's nothing more than .desktop files.

In /opt, I have just 2 .zip files and their respective extracted contents, from when I was trying to install some missing libraries.

In /bin, there is no 7kaa stuff at all, no folders, no files. In /usr/share, also no 7kaa stuff.

In /home/$USER/.local/share/7kfans.com/, I have a few save files from my test play and 2 DAT files for settings stuff. Then, there's the folder I created, where I placed and then extracted the source tar file, in /home/$USER/AXIA/. In there is the 7kaa build folder and files.

In /usr/local/bin/7kaa, there's a 7kaa file, no extension, almost 27Mb size. When I click in properties in it, it says "shared library (application/x-sharedlib)".

In /usr/local/share/7kaa, there are a lot of files from 7kaa installation. I'd say almost all there are in build folder, but no 7kaa file.

In /usr/local/share/doc/7kaa, there are some text files, readme and such.

In /var/lib/app-info/icons/ubuntu-focal-universe/64x64/7kaa_7kaa.png, I believe there's a possible icon I could use for the shortcut, when I create it.

Side question 1: Can the build files and folders be safely deleted after a successful install from source code? Or are they still needed?

Side question 2: I just remembered I should have said before that I had previously installed this 7kaa game from Software app (Software/Games/Seven_Kingdoms), with its source being "ubuntu-focal-universe".

I removed it because it wasn't updated, nor it seemed it was ever going to be. In it's page in Software app, it says "Updated --> Never". It's a rather old version. That's why I decided to build it from the fan site and learn some linux stuff in that process.

When we click to remove an app from Software, repository or whatever it's called, are all those files really removed or do some (a lot?) of them still linger in the system?

Yes.

A lot lingers. I do not use that Software Store app, at all.
You can remove using the terminal or using Synaptic to get a better cleaning.
If you use Software Store, then Bleachbit may be for you.

I highly recommend you install the Word Suggestions add-on for terminal:

1 Like

I had no idea there could be a sort of a GUI for terminal. :sweat_smile: Thanks! I'll try that later.

Installing something now, say Bleachbit like you suggested, would it remove the lingering files from previous incomplete uninstalls?

I'm starting to think I should delete all 7kaa related and try a fresh build/install.

Another side question: Unlike in Windows, where we can select the directory where most of the files in a installation go, in Linux we can't really choose, right?

It goes to the usual system folders, like all/most applications, if I'm understanding correctly. There is a predestined place for them for it to work properly in linux and that doesn't change.