Newbie problems: Video conferencing, Skye/Duo etc

Hi there,

Really loving this Zorin lite. I was using Puppy on my old Atom Netbook but this one looks really nice :slight_smile:
Using it on a Toshiba NB510-115. Specs:
https://pt.dynabook.com/discontinued-products/toshiba-nb510-115/

So, i am having a few issues. The camera works fine on Cheese, but in Chromium using Google Duo it dosent recognize the camera.
Also i installed Skye from the repository but it dosent load. When i use the terminal and type “skype” nothing happens also.
The other minor thing is that the touch pad only work for movement, not for clicks. I have a mouse, so not a deal breaker.
Like i said, i am a newbie so i appreciate any help.

I plan to use this as a teaching machine for my 4yo and i think linux is the way to go. Already installed Gcompris and lots of old-school emulators (yes, its for the kids honey!!)

Best regards,
R.

Some manufacturers have a keyboard toggle that enables and disables the camera. For example fn+F6 or some other obscure combination.
Can you check your manufacturer and specs for such a toggle?

For Skype, the snap package is problematic. Are you using the snap version?
Recommended is the .deb file direct from Skype:
https://www.skype.com/en/get-skype/

Hi, You do know that there is Zorin Education Lite don’t you? That comes with GCompris in the .iso plus tons of other educational applications. :wink:

https://sourceforge.net/projects/zorin-os/files/15/Zorin-OS-15.3-Education-Lite-32-bit.iso/download

https://sourceforge.net/projects/zorin-os/files/15/Zorin-OS-15.3-Education-Lite-64-bit.iso/download

I does not have a camera fn. i will search some more.

Skype i am using the snap, i assumed that in linux its always best to use the built in tools. I will install this one and try again.

Thanks!

Hi,

I didnt know that :slight_smile: thanks.
Is there any difference on the zorin itself, or is it just the same but with a bundle of software installed? If so, isnt it the same just keep the regular zorin and install the app i want? I can see that some of the apps are a bit to advance for now. My little one is only now leaning the first letters :slight_smile:

I will be blunt and politically incorrect.

As a lot of people migrated to Linux from Windows due to them being unhappy with Windows Costs, they brought along with them the way Windows had Trained them to view home computing.
In other words: Laziness.
These newcomer users came in large enough numbers, complaining about how in Windows, installations were easy. They wanted the same in Linux.
Sadly, perceptions matter.

In Windows, installations are easy only when they work. When they do not, you are at such a loss of control, it is exceptionally hard to fix or diagnose.
Windows installations include all dependencies and extras that the installation MAY need, regardless of whether or not the computer already has such installed.
With Linux installs, the user had full control. If an installation fails, the terminal tells you why and how to fix it. And you install only what you need.

Canonicals answer to this cryout for Windows Style Installations was the Snap Package system. Snap is self contained, including all dependencies, in one installer. It brings Bloat to your computer and it removes much of the control. Snap packages do not play well with system themes or icons. And if a Snap package goes awry, there is little you can do.

Flatpack and Snap do go wrong sometimes. They require more maintenance. So, as Ubuntu will push their Snap packages, going so far as to include them in the Software Store… without really giving much warning that that is what it is… they are worth avoiding.

It is not my desire to be rude. Sometimes, ya just gotta tell it like it is.
In the meantime, linux users are now complaining about running out of room in their Root folder or home partition so easily now…

Zorin is the same for both.
If you would like some of the apps on Zorin Education that you see listed in the preview of Zorin Education’s download page, you can install any of those apps from your terminal or preferred package manager like Synaptic.

Just found this page which MAY have some helpful tips to fix the issue:

I just had the same problem. I used sudo modprobe uvcvideo to reconnect/reinitialize the camera.

This answer is saying to enter into a terminal:

sudo modprobe uvcvideo

The next answer on the page that has potential is:

Using preload was the only thing that worked for me on an old camera (USB2.0 webcam) with Ubuntu 18.04, fully updated.
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/bin/skypeforlinux

This answer is more complex. It links to a page that gives instructions, but if you have never made a bash script before, it can appear overwhelming. It’s actually quite easy.
If you would like to try this suggestion, but the instructions look like they have fangs and claws, please ask here and we can break it down step by step.

Thanks for all the detail. I started with Unix and Dos long time ago, so i dont mind at all the command line :slight_smile: I just want to make sure i am doing it the best possible way. Sadly my exposure to Linux has been far and wide (work makes me use MS systems always) so i appreciate the honest feedback.
This netbook had Puppy for the last couple of years, but all worked out of the box, so i didnt had to learn much. I think this will be a learning tool for my child but also for me :slight_smile:

I will keep this version and just install the apps i want. In doubt i will google for the command line installation options.

Thanks!

Thanks, i will review all the above and return with questions :slight_smile: