No audio on 2017 27" iMac

I've submitted a trouble ticket but don't think that the Zorin crew will get to mine before my Zoom call tomorrow. So, I'm hoping someone has some spare fairy dust to share.

It seems my sound card isn't being recognized on my 2017 27" 5K iMac... In fact, I'm getting "Dummy Output" when running alsamixer...

I've already seen the FAQs on the Zorin site regarding this very problem but the one "fix" doesn't actually fix anything.

Alsamixer output screenshot:

If anyone can help me, I'd proudly bow down in your honor!!! :slight_smile:

1 Like

Have you yet tried adding options snd-hda-intel model=imac27_122 to /etc/modprobe.d/alsa-base.conf?

You can do this in terminal:

sudo nano /etc/modprobe.d/alsa-base.conf

Page down key to the very bottom, then paste the option parameter in.
Tap ctrl+x to exit the editor, then y key to say yes to save, then enter key to save current configuration.

Or with GUI:

sudo -i

Zorin Core / Pro


Zorin Lite / Pro Lite:


navigate to "Other Locations" then "Computer"
Then the path /etc/modprobe.d and open alsa-base.conf with Text editor.
Paste the snippet at the bottom:
options snd-hda-intel model=imac27_122
Save the file
Exit the Elevated Root Terminal and File Manager.

Thunar: tap the Up Arrow twice on the toolbar, then navigate to path /etc... and proceed as above.

1 Like

What would I paste in the .conf file if I have a 2018 macbook pro?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.