No Audio on Zenbook Pro Duo

Hi I'm brand new to Zorin and Linux in general. Trying to make the switch away from Apple and Microsoft and I like Zorin so far but I can't get audio working on my new laptop. Weirdly the system settings sees the internal speakers and microphone. When I speak I can see the microphone meter bounce and when I play music from Spotify I can see the audio meter bouncing but I still can't hear anything. Volume of course is all the way up.

I have gone through several tips from forums trying to adjust settings in Alsa Mixer and using Pulse audio to make sure nothing is muted and volume is up. I've updated all the latest drivers. I tried everything from this blog post

When I boot up in Windows it works fine. I can hear everything but nothing in Zorin. Any help would be appreciated.

If you tried everything in alsamixer and pulseuadio, you could try with a more recent kernel and see if it fix the problem. It's a shot no guarantee.

sudo add-apt-repository ppa:tuxinvader/lts-mainline -y
sudo apt update && sudo apt upgrade

First try with kernel 5.15

sudo apt-get install linux-generic-5.15

or the latest

sudo apt-get install linux-generic-5.16


1 Like

@Storm thanks for the help. I installed 5.15 still no audio. Then I installed 5.16 and now the machine has trouble booting. I'm having to boot Zorin with advanced options and choose 5.13 on boot in order to get things working. I tried uninstalling 5.16 kernal but its still not booting normally. And still no audio. I'm wondering if I should wipe the machine and try a fresh install of Zorin.

A clean install is quicker than figure out what went wrong and fix it.
What brand and spec of your audio card?

I did a fresh reinstall but still no audio. Wiped the whole drive just to be safe. The sound card is HDA Intel PCH Realtech ALC294. This may be the end of my Linux experiment if I can't get this working. :frowning: I need to be able to do video conferences for my job.

It seems that the sound card you are using are sparse supported on Linux for what I'm reading on the web.

But try this: gnome - My volume is either max volume or muted, no middle ground - Ask Ubuntu

instead of vi use nano

Thanks again for all your help. This didn't work for me either. I'm not sure if I saved the file correctly after i edited it. I just saved it as the same name "common". Either way still no sound.

@Aravisian do you have any idea? I'm out of suggestions.

Okay try this;

sudo nano /etc/modprobe.d/alsa-base.conf

add following;

options snd-hda-intel model=asus-zenbook

Save, exit and rebboot

May also try this;

scroll down to:

sudo nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=asus-zenbook

Where should I insert this text in the conf file? See below in bold. Is this the correct place?

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-hda-intel model=asus-zenbook

Ubuntu #62691, enable MPU for snd-cmipci

options snd-cmipci mpu_port=0x330 fm_port=0x388

Keep snd-pcsp from being loaded as first soundcard

options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

options snd-usb-audio index=-2

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.