No audio with internal speakers

I can see the vumeter moving in zorin sound settings when I perform a sound test but I can't heard nothing. If I plug a headset in jack I can hear the sound test.
I installed the pulse audio following other post solutions here, if some one can help me.
I don't remember in which zorin version did it stop working.
Thank you!

toni@hp-compaq-6730s:~$ sudo lshw -C sound
[sudo] contraseña para toni:        
       descripción: Vídeo
       producto: CKF7063
       fabricante: Chicony Electronics Co., Ltd.
       id físico: 5
       información del bus: usb@1:5
       versión: 33.19
       serie: SN0001
       capacidades: usb-2.00
       configuración: driver=uvcvideo maxpower=98mA speed=480Mbit/s
       descripción: Audio device
       producto: 82801I (ICH9 Family) HD Audio Controller
       fabricante: Intel Corporation
       id físico: 1b
       información del bus: pci@0000:00:1b.0
       versión: 03
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list
       configuración: driver=snd_hda_intel latency=0
       recursos: irq:32 memoria:d8900000-d8903fff
toni@hp-compaq-6730s:~$ lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
	Subsystem: Hewlett-Packard Company 82801I (ICH9 Family) HD Audio Controller [103c:3614]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
toni@hp-compaq-6730s:~$ sudo dmesg|grep audio
[   10.536295] snd_hda_codec_analog hdaudioC0D0: autoconfig for AD1984A: line_outs=1 (0x16/0x0/0x0/0x0/0x0) type:speaker
[   10.536307] snd_hda_codec_analog hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   10.536312] snd_hda_codec_analog hdaudioC0D0:    hp_outs=1 (0x11/0x0/0x0/0x0/0x0)
[   10.536316] snd_hda_codec_analog hdaudioC0D0:    mono: mono_out=0x0
[   10.536319] snd_hda_codec_analog hdaudioC0D0:    inputs:
[   10.536322] snd_hda_codec_analog hdaudioC0D0:      Internal Mic=0x15
[   10.536326] snd_hda_codec_analog hdaudioC0D0:      Front Mic=0x14
[   10.536329] snd_hda_codec_analog hdaudioC0D0:      Line=0x1c

My other info to avoid "analog" error in forum:

1 Like

Changed your original post to OCD error. Please refrain from attempts to bypass the word filter, it is present for a reason. This is a family friendly forum and we aim to keep it that way.

The FAQ and Intoduction to General Help may assist you in future posts.


In your Sound Settings, is Output/output device in dropdown list for sound test set to speakers or headset?
Try with speakers selected with headset disconnected.

In alsamixer, Look for [automute] channel and try that set to Disabled.

In alsamixer, Look for [Loop-back] channel and try that set to Disabled or Enabled to see any effect.

In alsamixer unmute (type M) at all your output channels and increase volume level to see effect.

In alsamixer hit F6 to see if any other sound cards listed.


I don't quite understand what you are saying, I wasn't trying to bypass anything, the error the forum gave me when I tried to attach what I had to put in Pastebin said that word. Maybe you should change the word in the error message if you want it to be family friendly.

1 Like

Hi, thanks for replying, I have gone to do the first check you indicated and the sound works.
I do not understand what has changed. I updated the software yesterday with the pending updates, but I don't think that fixed it. I also did as indicated here to be able to install Odoo. is it possible that something related to python or the apt-get --fix-broken install command fixed it?

Both volume indicators have always worked for me (mic and speakers) but this is when I can hear it.
The drop-down only shows speakers - internal audio, have always shown this device unless I plug the headset into the jack.

I changed the automute option as you told me.
I didn't want to change the others as I don't know very well what they do and the sound is currently playing.

Many thanks to both of you for your answers. I am left wondering how to fix it if it happens again. :sweat_smile:


This was confusing... I looked into it by checking the file in the pastebin.
It was the word analog that tripped the filter:

tarjeta 0: Intel [HDA Intel], dispositivo 0: AD1984A Analog [AD1984A Analog]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0
arjeta 0: Intel [HDA Intel], dispositivo 2: AD1984A Alt Analog [AD1984A Alt Analog]

We will see if we can fix this forum side...

1 Like

Testing post:







Found it:

It is a linguistic issue. The ó is not recognized resulting in the word read stopping at the "l" just before it.


You had to type it to receive that error. That is the word filter responding to what you typed.

1 Like

haha, I understand now, thanks for the clarification @Aravisian @337harvey , I did not understand the problem before. :rofl:
Thank you both.


From your latest alsamixer screenshots, I see both your [Headphone] and [Speaker] channels are unmuted and volume level set midway. Pleased to hear your sound is now working.

You should save your working alsamixer settings using:

sudo alsactl store

Note: I find fixing sound problems on Linux is sometimes more luck than judgement. Sometimes if you play around with alsamixer, it comes good for no logical reason.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Hi, as the previous time it was solved without knowing exactly how, I wanted to add the following in case it helps anyone.

In a recent update I lost my internal speakers audio again.
I found this topic today:

To me work a solution given in the comments.

I appended at the end of the file /etc/modprobe.d/alsa-base.conf the command "options snd-hda-intel index=1"
After reboot, internal speakers are working again.


Sos un genio! Tenia un problema; el audio salia por los auriculares pero al cambiar el dispositivo de salida y seleccionar los parlantes no se reproducía el sonido. Lo solucione en alsamixer colocando el canal [automute] en Disabled.
Mil gracias genio! Saludos desde Argentina!


translation: You're a genius! I had a problem; The audio was coming out of the headphones, but changing the output device and selecting the speakers did not play the sound. I fixed this in alsamixer by setting the [automute] channel to Disabled. Thank you so much genius! Greetings from Argentina!
@marianoInsa Good to hear your sound is now working through speakers. Sound problems are not always easy to fix. :+1:

Make sure you save your working alsamixer settings using:

sudo alsactl store
1 Like