No Bluetooth connection to the speaker

I have just installed the new Zorin OS 17 Pro on the HP Elitebook x360. I am unable to stream sound via Bluetooth to an external speaker. (I previously had a MacBook with which it worked without any problems).

What have I done? The external speaker and Bluetooth are activated. On my computer, under Settings > Bluetooth, the wheel runs continuously. In the meantime, I have also installed the Blueman Bluetooth Manager app. Here, too, the external speaker is not displayed when I activate the search.

What can I do? (Unfortunately, I have no experience with terminals.) I would appreciate any help. I have not been able to find anything in the forums.

Can you please relay the terminal output for

sudo lshw -C network

Bluetooth is broadcast under radio which is part of your Wifi setup.

Open a terminal. Type

inxi --usb


Copy and paste the output (text) here.

Hi guys, thank you very much for your quick support. I have entered the code in the terminal. I then let the Bluetooth Manager search for the speaker, but it didn't find anything. What else do I need to do? (Sorry for asking, but I'm a greenhorn when it comes to coding).

tim@tim:~$ inxi --usb
Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
Device-1: 1-5:2 info: HP HP lt4132 LTE/HSPA+ 4G Module type: N/A rev: 2.0
Device-2: 1-6:3 info: Validity Sensors type: rev: 2.0
Device-3: 1-7:4 info: Chicony HP HD Camera type: Video rev: 2.0
Device-4: 1-8:5 info: Chicony HP IR Camera type: Video rev: 2.0
Device-5: 1-9:6 info: Intel Bluetooth wireless interface type: Bluetooth
rev: 2.0
Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0
tim@tim:~$ sudo lshw -C network
[sudo] Passwort für tim:
Beschreibung: Kabellose Verbindung
Produkt: Wireless 8265 / 8275
Hersteller: Intel Corporation
Physische ID: 0
Bus-Informationen: pci@0000:3a:00.0
Logischer Name: wlp58s0
Version: 78
Seriennummer: 18:56:80:0c:8c:f3
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pm msi pciexpress bus_master cap_list ethernet physical wireless
Konfiguration: broadcast=yes driver=iwlwifi driverversion=6.5.0-15-generic firmware=36.ca7b901d.0 8265-36.ucode ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
Ressourcen: irq:136 memory:e6300000-e6301fff
tim@tim:~$ ^C
tim@tim:~$ ^C

According to this, it should be working and supported.

Can you check your BIOS / EFI settings for USB settings or if you have installed the linux package usbguard?

Hi Aravisian, thank you very much for your reply. I have also just downloaded the usbguard package installed, which had no success. How and where can I check the BIOS/EFI settings for USB setttings? And what does Bluetooth actually have to do with USB?

There is a bug in USBGuard that will cause bluetooth to endlessly circle, so I wanted to check if you had that.

Many bluetooth devices route through USB. While not all do, they are common (my own wireless mouse connects through a small USB dongle that must be plugged into the computer) and this can be a primary point for communication failure.

Many manufacturers offer settings for peripherals but locating them is dependent on the manufacturer so it must be looked up by device.

Many thanks for your support. I have just checked the USB settings. They are all enabled. Is there perhaps another approach?

In blueman, when you set to search for connections, speaker set to pairing, does the speaker show up?

I looked at it again and was able to pair the external speaker, but: I can't find the external speaker to select in Settings > Audio. After some research, I installed PulseAudio Volume Control: But even there I don't have the external speaker in the selection. What else can I do? Many thanks for any help.



what does it show in the Output tab? Also, what is listed available in the dropdown menu?

Hallelujah, it finally worked. I don't know exactly why. Anyway, it "suddenly" had an audio source selection. Now I just have to find out what to look out for. Thanks again for your constant support! Best regards from Switzerland.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.