No Bootable Device found

I have done a clean install with Zorin OS 15.3 to 16.0 but now i have this problem down below:

Default Boot Device Missing Or Boot Failed. Insert Recovery Media and Hit any Key Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media.

After that: Option Menu

1.Unkown Device: (WDC WD5000LPCX-21VHAT0)


I have tried with boot-repair from this site:

But then i get like this below:

After that: Option Menu

1.Unkown Device: (WDC WD5000LPCX-21VHAT0)

2.Unkown Device: (WDC WD5000LPCX-21VHAT0)


After i have done boot-repair.

And after that i tested to go into the BIOS and change BOOT UEFI to Legacy but that didn't work it become worse so i had to change back it into UEFI?

I have Acer-Aspire computer?

How can i solve this i have tested 2 solutions already?

Could you tell me how you created installation media?
For Zorin 16, Etcher is the recommended.
Also please make sure that you have downloaded the (fixed) version of Zorin 16. The earlier version has Ubuntu upstream bug.

I used Ubuntu Disk to recreate the ISO-Image file?
I downloaded the ISO-file from here Download - Zorin OS

That seems to be the problem.
I tested all sorts of Live USB creators, the only thing that worked was Etcher.
I recommend you to make another installer with Etcher.

Does etcher exists on Ubuntu?

Yes, as an AppImage:

I used Ventoy to install Zorin. Belena etcher is good also.

I hope they create a Path so that you can skip a clean install with USB to next release of Zorin 16.1 or 17.0?

There will be an upgrade path later this year.
But you have to wait.