No display after restarting PC

Hello! I have been using Zorin for about 2-3 weeks now and I keep having this constant issue.Briefly, my PC when it is shut down has no problem booting into Zorin first try but when I have to restart(From PC case or OS), my PC is functioning properly but I have no display whatsoever. The only fix I have found is to attempt to restart my PC 3-4 times to boot me into the OS with display or just shut the power of my PC completely and boot it again.

Useful info you might need: GPU: RX560 4gb
Monitor: AOC 24G2U

Thanks in advance !

Can you check your error logs (You can use pastebin so we can analyze them here):

What graphics Card are you using?

2 Likes

I am using a MSI Radeon RX 560 4GB Aero ITX, as for the error logs, which ones are of importance to you ?

/var/log/kern.log

/var/log/boot/log

You can use pastebin to relay the logs.

Logs - Pastebin.com I suppose these are the logs you might need. Thanks for your commitment btw !!

Are you using Hibernate? Do you have Swap on a separate partition? (For Hibernate, Swap should have its own partition.)

I recommend for now that you roll back to the 5.11.0-27 kernel. The 5.11.0-34 appears to have some bugs. You can do this from the Boot Menu - hold the left shift key at boot, then on Advanced Options for Zorin, select the -27 kernel to boot from.

Your AMD graphics drivers:
In terminal, add the AMD drivers repo:

sudo add-apt-repository ppa:oibaf/graphics-drivers

Then

sudo apt update && sudo apt full-upgrade

I am not using hibernate,also it doesn't let me add the repository and I get these error messages [E: The repository 'http://ppa.launchpad.net/oguzhaninan/stacer/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.]

As far as the kernel is concerned I will test this right now and edit the post to respond how it went.

Can you clarify this?
You can remove the Stacer Repository from Software & Updates. scan the list in "other Software" tab for ppa.launchpad.net/oguzhaninan/stacer/ubuntu - When you find it, click on it to select it, then click the Remvoe Button on the bottom toolbar.

Then run sudo apt update.

You said it doe snot let you add the Oibaf/drivers repo - is there an error?

Ok firstly,booting from another kernel didn't solve the issue, also the drivers have been installed after I followed your instructions.

From this, it appears neither solved the issue.

I am not seeing anything else in the boot log to depict any errors that would cause what you are experiencing...

What about ~/.xsession-errors?

I can't seem to find that file...isn't it somewhere into the Home directory ?

Yes, the Home Directory. But, it only exists if errors have been logged from your session.

The files with a period in front of them are revealed by the keyboard shortcut ctrl+h

Yes, it's not there currently

The only thing I can think of that may cause this - without leaving an error log trace - would be the X Window manager having a corruption within the files. Sadly, the only solution I know of would be to fully Reinstall Zorin OS.
Perhaps other users can chime in with other ideas...

1 Like

I am afraid this might be my only bet aswell. Thank you very much for you effort, I appreciate it !

2 Likes