No global IPv6 address despite DHCP6 enabled

Hi there,

I've installed Zorin OS 16.2 on an old Lenovo Thinkpad T560 and everything works fine - except IPv6.

All my computers are behind a FritzBox 6660 that should be dealing out IPv6 addresses via DHCP6. This works for all my computers, running Ubuntu 18.4, macOS 13 Ventura and Windows 10 - the only one that only gets a local IPv6 address is my laptop running Zorin OS.

In the network settings, I've configured "Automatic / DHCP only". Still, I only get a local IPv6 address, and other computers on the network can't be reached via IPv6 (message: "network is unreachable").

How can I get this to work?

Gday @ronin2 , Welcome to the community!

Try this link,

1 Like

Hi Ocka,

the guide from your link doesn't work in my system.

First, /etc/network/interfaces doesn't exist on Zorin 16.2, I guess it's because networking is managed by NetworkManager, so it's probably ignored anyway.

Still, I created the file and entered the contents as described in the guide, but when I issue

service networking restart

logged in as root, I get the message

Failed to restart networking.service: Unit networking.service not found.

Maybe this could help you: networking - Problem to restart network - Ask Ubuntu

Thanks zabadabadoo, the error message is now gone, but the problem still persists: My interface doesn't get a global IPv6 address.

First I tried to assign a static IPv6 address as detailed in the guide under Ocka's link, then I tried to specify iface wlp4s0 inet6 dhcp to get it to assign a dynamic address, but in both cases, the settings were simply ignored and no global IPv6 address was assigned to the interface.

Any other ideas?

From another websearch I found this:

I dont know if anything there will give you a clue.

Hi Zabadabadoo, the post doesn't seem to be too closely related to my problem; the poster does get an IPv6 address, has an entirely different network setup, and while they don't tell what distro they use, it doesn't seem to be Zorin, but something that doesn't use NetworkManager.

Gday @ronin2 ,

Could you please check for firmware updates on BOTH your thinkpad & the FritzBox, are up to date.

Check the firewall & see if your getting ipv6 addressing, (blocked/unblocked).

You could install "Wireshark" & see where the issue is.

IF you still have issues could you show us the results of this command please,

sudo lshw -C network

Hi Ocka, thanks for your reply.

the thinkpad has the latest firmware (which doesn't mean much since it's from 2017). My FritzOS is 7.29 which is not the newest available but the newest my internet provider will allow (the FritzBox is managed by the provider).

The firewall on Zorin is disabled and there is no other firewall involved.

I've installed Wireshark and I'm apparently able to capture traffic on the Wifi interface, but I don't know what to look for.

sudo lshw -C network gives the following output:

  *-network                 
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 3a
       serial: b8:8a:60:da:9e:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-76-generic firmware=36.77d01142.0 8000C-36.ucode ip=192.168.178.48 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:130 memory:e1000000-e1001fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: 54:ee:75:b3:d8:4e
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.15.0-76-generic firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:124 memory:e1200000-e121ffff
  *-network DISABLED
       description: Ethernet interface
       physical id: 3
       bus info: usb@1:2
       logical name: wwx021e101f0000
       serial: 02:1e:10:1f:00:00
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=cdc_ether driverversion=5.15.0-76-generic duplex=half firmware=Mobile Broadband Network Device link=no multicast=yes port=twisted pair

Maybe check that the options are enabled on Zorin by the /etc/sysctl.conf. You can use this link to force IPv6 to be used.

Your card may not share that it is IPv6 capable...though it is.

Hi 337harvey, that's the same link I got from Ocka, and I've already tried that. IPv6 is enabled and the system supports it, it just doesn't get an address from DHCP. A local address is auto-assigned, and when I try to ping6 any host, I get "network is unreachable".

Forgive me for duplicating the already offered link.

Have you tried manually configuring the gateway. Static address and dns in order to see if you can connect?

Have you tried restarting the router, forcing the restart of the service?

Look in your /etc/network/interfaces and see if wlp4s0 has the line iface wlp4s0 inet6 auto.

If that doesn't work, you may try editing /etc/gai.conf and removing label fc00::/7 6 # ULA which may restore dhcpv6. I got my information from networking - Linux not preferring ipv6 on dhcpv6 network - Super User.

Hello 337harvey,

thanks for the reply. As mentioned, Zorin is a NetworkManager based distribution and as such doesn't have /etc/network/interfaces. The file doesn't exist and even if created, it's ignored.
/etc/gai.conf doesn't contain any active settings, only comments, so there's nothing to remove.

However as of yesterday, the problem weirdly seems to have disappeared. IPv6 addresses are now assigned automatically via DHCP.

All I did was installing the .deb packaged version of Wireshark (NOT the flatpak); apparently some of the dependencies that came with it fixed the problem.

1 Like

It may not have been a dependency, but rather the service is enabled by wireshark, in order to access both IPv4/6 traffic.

I believe that the interfaces would be accessed, if you have iptables installed, instead of ufw. I may have missed sharing that after my reading...was fresh in my mind, but I had forgotten to pass along what I had read and the prerequisites.

I am only posting to second this; a dependency would not really make sense. A Driver is a Driver.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.