No Grub, can't boot into windows

I installed Zorin Core 17.1 using the something else radio button.

Last time using linux was years ago with Ubuntu and everything went fine dual booting.

I had already made space on my internal HDD in windows so made a new partition through the installer wizard and installed to there.

Once I rebooted there was no grub menu to select OS.

I cant seem to get into a grub menu with any button presses – shift or c etc.

I tried the zorin live USB desktop to maybe use a bootloader fixer but zorin doesn’t seem to have wifi drivers on the live USB OS.

Similar to this advice

Do I need to have a ubuntu live USB?

I can mount the windows partition within Zorin and files all fine.

what can I do to try to get a grub and access to my windows OS?

installed grub emu and got this result:

Ok, some nervous fiddling with Bios and making a new boot path i have managed to get back into windows.

but bit of a faff having to use the laptops boot selector either time i want to change OS.

so initial question still stands if anyone can help.

Open a terminal and type the following commands:

sudo os-prober

If it shows the Windows boot path then run:

sudo update-grub

This should fix the issue and Windows will show in the grub menu. Keep an eye on the outputs of these commands If any error shows up then share here.

didnt work. i've copied the error.
i've never managed to get a grub selection screen. basically if i dont go into the quick boot loader then it always auto boots into zorin

spoo@spoo-XPS-13-9343:~$ sudo os-prober
[sudo] password for spoo:
/dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
spoo@spoo-XPS-13-9343:~$ sudo update-grub
Sourcing file /etc/default/grub' Sourcing file /etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/zorin/theme.txt
Found linux image: /boot/vmlinuz-6.5.0-26-generic
Found initrd image: /boot/initrd.img-6.5.0-26-generic
Found linux image: /boot/vmlinuz-6.5.0-21-generic
Found initrd image: /boot/initrd.img-6.5.0-21-generic
Memtest86+ needs a 16-bit boot, that is not available on EFI, exiting
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done

Your partition layout looks odd with an 'unknown partition' followed by about a Gb of free space. What version of Windows is on the drive?

1 Like

win10
new weird quirk that the soundcard occasionally doesnt get recognised in windows now

Welcome To the Forum!

Can I ask why You haven chosen this Option? Wasn't Windows 10 detected by the Installer? The Installer should gave You the Option to install Zorin alongside Windows. This makes the Process more easier.

Sounds like your grub may have been installed on an extremely drive (usb maybe). Reinstall, using something else, don't format, be sure to choose the partition for the grub, not just the drive.... this way you know where it's going... at the partition format screen.

This should give you grub with access to both OSs.

I'm not sure about the Memtest86+ error but lets first try to fix the os-prober warning. Open terminal and run:

sudo gedit /etc/default/grub

Now look for the line GRUB_DISABLE_OS_PROBER,

  • if it exists then set it value from the true -> false
  • if it doesn't exist then just add this line at the end of the file
  • GRUB_DISABLE_OS_PROBER=false

  • save the file and exit the editor and then run:
sudo update-grub

When I did the initial install it said no previous OS detected or something similar. Didnt want to accidentally wipe the OS partition.

reinstall zorin and make a new partition for grub?

Yes, at least 500mb. Don't format root. Install grub to the new 500mb fat32 partition. Should resolve your issue.

So, you didn't had that Screen with the first Option:

And then you chose the ''Something else'' Option. Okay, I understand. Then You should got a Screen like this to make the Partitions:

Here is the Point the Dropdown Menu. Look at it if You have the Windows Boot Manager and choose this for ''Device for boot loader Installation'' so you don't have to create a seperate Fat32 Partition.

and for your free Space for the System You see the marked Option over that. there is only the Mounting Point / so You don't must create seperate Partitions for home and root and other Stuff.