No GRUB, No WiFi Device in `lshw` on Dell Venue 11 Pro

I'm trying to install Zorin on a Dell Venue 11 Pro 5130 2-in-1 tablet as it seems a recent Windows 10 security update is incompatible and keeps killing it. This is a ~10 year old device which originally shipped with Windows 8 and has been running Windows 10 Pro for the last few years, mostly without issue.

I disabled Secure Boot and installed Zorin 17.1 Core from a Ventoy USB stick but there was a "fatal error" during the grub installation step. Sure enough, the OS won't boot natively but is accessible via Super Grub 2 Disk and works fine, except for WiFi which I'll get to in a second. I've tried booting the live image again and using the "boot repair" tool, but this also fails and says the NVRAM is locked. I've tried looking online but the only real options I can find are fiddling with a CMOS jumper (inaccessible to me, if it exists on this tablet) and resetting BIOS to defaults. I tried the latter and ran boot repair again, to no avail. Any ideas?

Regarding WiFi, the device simply isn't recognised. This tablet has a 3G modem "broadband" card which is recognised, and shows a USB device under lshw and lsusb but neither they, nor lspci indicate anything regarding WiFi. I have run Software Updater, rebooted, opened it again and then checked for proprietary drivers but none were found. Funnily enough, it's a combined WiFi + Bluetooth chip (or at least a combined driver under Windows) and Zorin does seem to recognise the Bluetooth aspect, just not WiFi. Any ideas?

Digging into the Win8/10 drivers for this, they are Dell-branded with references like "Dell Wireless 1538" or "DW1538" or "Wireless WLAN BT 1538C", but it is a Qualcom Atheros of some sort - I think QCA6234. I have tried searching for Dell 1538 / QCA6234 drivers for linux online and found practically no results, only that a the ath10k driver series in the linux kernel supports QCA6174. So close, yet so far.

This thing only has 1 USB port, so sacrificing it to a permanently fitted WiFi dongle would be... less than ideal.

Hi, I suspect your issue is because Ubuntu (on which Zorin is based) does not provide 32-bit UEFI support!:

You might be better off choosing a 32-bit distribution, such as Antix, MX-Linux, Devuan

1 Like

Ah, I was hoping that would not be the case, given the Zorin ISO did boot and install from Ventoy and the installed system does run fine once you trick it into booting without a local grub to handle things. It's incredibly frustrating as the CPU in this thing definitely is 64bit, but the (U)EFI isn't!

I'll keep playing with this, I have found mention that 32bit Grub2 is happy to boot 64bit UEFI operating systems, if you poke it in the right ways.

1: Installing linux on an 32bit UEFI only machine - Unix & Linux Stack Exchange
2: Ubuntu (or other Linux) on the Asus Transformer Book T100 | John Wells

If I get it working, I'll report back with my process.

For posterity regarding WiFi, I found another identifier in the Windows driver files - AR6004 - which is, again, technically already part of linux, but it's either incomplete or an updated version didn't get merged into mainline for some reason. The hw3.0 subfolder from this github repo copied into /lib/firmware/ath6k/AR6004 did the trick for me.

Obligatory don't trust random drivers and binaries you find online, I'm just doing this for fun and I won't be using it for anything important / personal so security on this device is not a big concern for me.

1 Like

I feel your frustration. I have an HP-Mini 110, which has a 64-bit Atom Processor but the main board only runs 32-bit.

1 Like

Gday @Ultrabenosaurus
The above fault maybe from "fast startup",
This is found within the Windows OS, follow the link below, just to disable Fast Startup.

I would also check the checksum of the download just to make sure it's been received in full.

Hope this helps

I have no idea if fast startup was enabled or not, but I completely replaced Windows when I installed Zorin, so I'm not in a dual-boot situation where fast startup could cause issues. I mean, surely that thing can't continue causing problems from beyond the grave, right?!

As for ISO integrity, I'm fairly sure I did at the time, but I can't right now as I haven't yet downloaded the r1 ISO (didn't know it had been released) and it looks like Zorin only list hashes for the latest edition of each branch, so I don't know what the hash should be to verify.

I'm downloading r1 now and will re-try the install, using the 32bit grub trick while I'm at it.

1 Like

I may revisit this again in the future, but for now I'm giving up and installing the official LMDE 32bit release.

I have tried following various guides, though all quite old, notably these in addition to my previous comments:

However, no matter what, I keep booting to a grub command line and have to manually type out the settings. Though I did run into dependency hell trouble installing the .deb packages recommended by the first link there, so technically didn't manage to complete that one as-written.

It's especially frustrating as the boot media for Zorin includes an 32bit EFI file (at least when writing it via Balena Etcher) which boots just fine from USB, and the resulting OS clearly is bootable from the grub command line; the darn thing just won't show my install as a menu option automatically!

Please, Zorin devs, I implore you to get this working out-of-the-box. I will even cheekily assert that, given the Zorin website regularly mentions breathing new life into old devices, doing so is not only in-line with your mission, but is actually an inherent part of it :wink: it would certainly give you another nice USP over Ubuntu and other distros to flaunt.

So here's my final post in this whirlwind adventure, laying out the last step of my journey to something is - at least for me - an acceptable trade-off and technically working. I leave this for my own future reference in case it breaks in the future, for @swarfendor437, and for anyone else with one of these cursed devices with mixed bit-depth from the dawn of Windows 8.1 looking to extend its godforsaken lifespan.

  1. Starting where I left off in my previous comment, LMDE 32bit installed fine using the default partition options to let it do what it wants, except the bootloader just vanished. Nothing visible even in the BIOS this time, though still bootable from Super Grub2 Disk.

  2. Installed Windows 10 Enterprise LTSC 2021 with the hope it would establish a baseline usable bootloader again, which it thankfully did. I didn't activate the install or change any settings, beyond saying no, f-u to most of the questions during initial setup before you get to the desktop; literally just install and reboot to confirm it worked.

  3. Re-installed LMDE 32bit, this time manually wiping out everything except the EFI System Partition (ESP) and Windows Recovery partition (not sure why I left the latter though), telling it to use the existing ESP for GRUB and the blank space for everything else. Upon rebooting, this resulted in Windows Boot Manager constantly trying to boot into the Recovery partition due to missing an actual Windows OS.

  4. From the accepted answer on this Super User thread, after using SG2D to boot into LMDE again, I ran the following commands:

sudo apt-get install --reinstall grub-efi
sudo grub-install --target=i386-efi --efi-directory=/boot/efi
sudo update-grub
sudo efibootmgr -c --disk /dev/sdX --part Y # for me it was more like `/dev/mmcblk2 --part 1` I think
sudo efibootmgr -v # verify new records called Linux and debian are there
sudo update-grub
  1. After disabling the Windows partitions from the boot sequence in my BIOS and setting the new "debian" as number 1, I was finally presented with a real, working grub boot menu that really worked and sent me into LMDE! Turns out, though, that LMDE is too resource-hungry for this little Intel Atom + 2GB tablet, idling at around 1.5GB of RAM usage. Just opening Firefox, without navigating to any page, was enough to grind the system to a halt...

  2. Booted into GPartEd (or use it via a live ISO) and shrank the LMDE partition to ~12GB (11444MiB), then installed Zorin 16.3 Lite using the "something else" option to specify the new ~50GB blank space for the OS and giving it the exact ESP partition (not just overall drive) to use for the bootloader. Thankfully this meant it didn't try to install its own 64bit grub and instead just hijacked LMDE's 32bit grub with its own Zorin config (much nicer theme btw!) allowing me to boot straight into either Zorin on LMDE at will.

On such a low-power device with such limited storage, this both is and isn't an issue. For me it's fine, as this tablet is only used for casual web browsing. For others, letting LMDE take up so much of their incredibly limited space may be a deal-breaker.

It could well be possible to also delete the Windows Recovery partition and modify step 3 above to install LMDE on a 12GB partition at the end of the drive, then install Zorin between the ESP and LMDE, and finally wipe LMDE and expand the Zorin partition to fill all the space... but I have no need to try this given my needs and the risk of it breaking the bootloader and leaving me to reinstall two, if not three, operating systems all over again.

As a final note, with 16.3 Lite using Xfce4, I recommend a couple of steps from this Reddit thread to enable one-finger touchscreen scrolling in Firefox:

  1. in about:config set the property dom.w3c_touch_events.enabled to 1
  2. edit / create one of /etc/environment or ~/.pam_environment with the content: MOZ_USE_XINPUT2=1
  3. reboot
2 Likes