No icon of discord

I have downloaded and installed Discord flatpak, however when it is open,it doesn't show it's logo instead show white logo page in panel. also my cursor icon theme doesn't work in discord app but it usually working outside of it.

Flatpak runs a closed bobble (sandbox) that's why. If there's a .deb package or PPA of Discord use that instead.

i did tried install .deb with apt install ./discord.deb but it was having dependency issue and wasn't installing.

Make sure you download ubuntu 20.04 .deb package if there are one. Else post the dependency problems you have.

i downloaded the official one from discord website.but no luck, does we have discord in zorin repo?

The following information may help to resolve the situation:

The following packages have unmet dependencies:
discord : Depends: libappindicator1 but it is not installable
Depends: libc++1 but it is not installable
E: Unable to correct problems, you have held broken packages.

Are you running Zorin 15 or 16?

That almost looks like a 32bit vs 64bit issue.

zorin 16 lite xfce

tested it in my machine, same error occure.

I never had this issue, but I always install Better Discord.

I got discord .deb to work. Simple run "fix broken package" in synaptic.

1 Like

Thanks! :face_with_hand_over_mouth:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.