No Internet After Crash While Proton VPN is On

(I don't exactly know what are the terms used in networking/CSS in linux, sorry in advance for using the wrong terms)

Normally, I don't have no issues with crashes, considering that there are not that much consequences after a crash; other than losing progress on a project.

During my work, I am using Proton VPN. I normally don't have any issues or crashes on my pc, so I assumed that it is just an another crash.

After I opened the chromium browser, it doesn't want to connect to anything. I even tried updating Zorin, it is says that its not online.

I've already tried bluetooth tehthering, usb tethering, removing the power from the laptop (it has removable battery), reconnecting the wifi connection, etc.

Also, I tried to use the mouse input from the zorin connect app, it apparently works, but not the internet connection on the laptop

Still no internet connection whatsoever... What should I do? Please help...


Uploading: IMG_20230705_104738.jpg...
Uploading: IMG_20230705_104213.jpg...

You can add screenshots to your post, by clicking the "Upload" icon on the Reply box toolbar.


try this:
How to Unistall ProtonVPN

This sometimes happens when using ProtonVPN‘s KillSwitch feature and afterwards experiencing a crash.

You‘d want to turn the feature off (if you can) or remove/revert all configurations added/modified by the ProtonVPN client.


before try this in terminal:

protonvpn-cli config -l && protonvpn-cli s

protonvpn-cli d && protonvpn-cli killswitch --off

sudo nmcli connection delete pvpn-ipv6leak-protection

First of all thank you for the replies, considering that I dont have that much knowledge about linux.... But after a couple of restarting my laptop, for some reason, it works normally again.

  1. File size limit is only up to 1mb, so I technically cant upload, it suggests via cloud sharing service.

  2. I found the option for the kill switch, but it is turned off when I found it, I'm still not sure what exactly happened.

  3. I've also included the specs oy my laptop if there is relevance on my situation.

  1. What is the command by eid for? If the command will have an issue on my laptop, what is the "reverse" for that command?

  2. If it's not the kill switch, what could be the other possible problem? (This also what happened to my friend's Raspberry Pi 4, also has the kill switch turned off)

you try and use image hosting like imagebam, imgbb, imgbox or something else.

just try using this:

protonvpn-cli d && protonvpn-cli killswitch --off

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.