No mouse and keyboard in Zorin 15 after booting Windows

Hi Everyone!

As the title says, I booted up Windows, restarted the PC and only the SSD with the Linux installation was turned on, the Windows SSD wasn't and I started Zorin os. In the beginning of the startup my optical mouse and the num lock light on my keyboard are glowing, then when the Zorin OS login screen appears both stop glowing and I can't use the mouse and keyboard.

I don't remember having this problem before.

Any suggestions?

Yes, it sounds as though Windows OS was not fully shut down. If Windows enters hibernation rather than Shutdown, it can retain control over hardware even after you boot into Linux.

You might try a Hard Reboot and try to then boot into Windows. Ensure that it does a proper Shutdown. Then test booting into Zorin OS and testing your hardware is all working.

I booted Windows up, than shut it down. The problem still persists. How do I know if it goes to hibernation?

when u normally shut down windows, it does not shut down completely. to shut down windows completely you need to disable fast startup.

Boot into windows

Go to Settings>System>Power and sleep.

Click on Additional power settings.

Click on Choose what power buttons do.

Then click on Change settings that are currently unavailable.

Uncheck Fast startup.

1 Like

Fast startup was already unchecked.

run journalctl -p err in the terminal and post the output u get

1 Like

It may be we are barking up the wrong tree...
When booting Zorin OS, select the Advanced Options for Zorin OS, then select an earlier kernel and try booting. See if mouse and keyboard retain functionality on login.
If not, reboot - Advanced options...
This time select Zorin OS (Recovery)
In the recovery menu, arrow key down to Enable Networking and enable network connection. Back out, then arrow key down to Root - drop to prompt.
In the terminal run

sudo apt install --reinstall xserver-xorg-input-all

Once complete, back out of the recovery menu and proceed to test a normal boot...

"When booting Zorin OS, select the Advanced Options for Zorin OS..."

I went into GRUB, booted Zorin but couldn't find earlier kernel options so I booted the OS in recovery mode and then couldn't select anything because mouse and keyboard were disabled.

Mouse and Keyboard were disabled even in the Recovery Menu?
That is very odd...
I have never even seen that happen before. At that point, they would be operating on the generic motherboard drivers just as seen here:

Some questions:

How long has Zorin OS been installed - how long have you not been experiencing this trouble?

Is this a Desktop PC with plugin Keyboard and Mouse or a notebook computer with built-in keyboard and mouse?

I don't remember. I must have installed it maybe a year ago.
I started experiencing this problem with the mouse and keyboard a couple of days ago when I booted up Windows for the first time in several months and then I switched back to Zorin.

I use a storage device power switch. When I want to use Windows or Zorin, I switch the corresponding SSD on and switch off every other storage device with a different OS installed on it.

It's a desktop. The plugin input devices work just fine on the same PC running Windows.

By plug-in, do you mean both mouse and keyboard are USB and are plugged directly into ports on your desktop (i.e. not via a USB hub or KVM switch or something similar)?

Yes, directly into USB 2.0 ports (not every device works if I plug them into USB 3.0 ports).

1 Like

So in summary: after booting ZorinOS (after booting Windows) you have no USB keyboard or mouse.
What is the effect of unplugging then reinserting the USB mouse and keyboard when ZorinOS is running. Are the USB devices then seen by ZorinOS once reinserted?

Also from Windows, did you choose "Restart" or "Shutdown" option when leaving Windows to boot ZorinOS. If you did "Shutdown", try the "Restart" option as a test.
(Restart should do a proper shutdown of Windows, although Shutdown with FastStart disabled should in theory give the same result - hence suggestion to test the theory)

Done it, I still have the problem.

Tried it, nothing changed.

The hard part is the inability to use the peripherals to run commands like lsusb while the user is logged in.
@ZorroOS , are you using gaming keyboard and mouse? What are the make and model of these devices?

OK. What happens if you boot ZorinOS Live USB, (assuming one of your USB ports still works for your bootable USB stick) and use the "Try ZorinOS" option.

Also as Aravisian is hinting, can you try a different mouse and keyboard and try these in all permutations of your USB ports.

Thinking aloud: I wonder if this switching off SSD's is the underlying issue, although I cannot fathom how, as it is not affecting the boot order or affecting ZorinOS from booting. Are there any additional Security options in your BIOS extra to Secure Boot?

Didn't help.

Keyboard and mouse are still disabled.

I'm using the same keyboard and mouse right now in Windows. They worked in Zorin too untill I previously booted Windows.

I couldn't find the Secure Boot option in the BIOS.
In Windows 10 I went into Device Security and there was no option for secure boot either.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.