No Mouse on Second Monitor

I run Zorin on a laptop connected to an HDMI monitor. With Zorin 16, there were no problems. I recently upgraded to Zorin 17 Pro and have noticed that when I wake my laptop up after going to sleep. I have to drag a window from the primary display to the external display to get the mouse to appear. The mouse is registered because I can see it highlight icons on the taskbar. But there is no cursor showing on the screen. If I open a window on my primary display and drag it over to the monitor, then it works fine until the system goes to sleep and the displays turn off. I don't want to have my displays constantly running, but I'm tired of opening a new window and dragging it to the screen just to get it to work. Opening a minimized window doesn't fix the problem. I have to open a new window and drag to the external monitor. Opening a minimized window may give me a mouse cursor while in the window, but as soon as it's closed, the mouse disappears.
Anyone have any similar problems?

Wondering if it is a sticky edges setting?

or misalignment:

1 Like

Welcome to the Forum!

You could try if the Problem still exists when You use X11 instead of Wayland because Zorin 17 run default with Wayland. You can change it on the Login Screen. Click on Your User Profile so that the Password Field appears. Then should be in the bottom right Corner a Gear Symbol. Click on it an you can change it.

Swarfendor437, thanks for the reply. None of those match what I'm seeing. It's a hidden cursor on the external monitor. The cursor moves to the external monitor but isn't displayed. If I move it to the bottom toolbar I can highlight icons but I don't get a cursor. And it only happens when the system blanks the screens or goes to sleep.

Ponce-De-Leon,
I'll give that a try and get back to you.
kg

1 Like

So I changes to X11. That worked... kind of. The monitor was green and I couldn't correct it. The primary display was fine, but the external monitor was green. Under Wayland, everything is fine, but X11, the external display turns everything green.

Hmm ... Maybe the Green Screen is a Graphic Driver Issue on X11. Let's see if @Aravisian can give an Advice.

What is the make / model of the notebook computer?

What graphics card(s) are in use?

sudo lshw -C video

Aravisian,
Sorry for the delay. I've using a Acer Predator Heilos 300 series laptop. The external monitor is AOC CQ27 G2 monitor connected to the HDMI port. The HDMI is an NVIDIA GeForce GTX1660 and the laptop display is using the Intel chip. The hardware list shows it's a CoffeeLake-H GT2 VGA compatible.
The AOC monitor works fine. If I open a something on my internal display then drag it over to the AOC, the problem goes away. If there's a window open on the AOC when I wake up the laptop, I have to move the window off the AOC and then back. It's just getting annoying.

This is an odd one...
I would check your Nvidia settings

nvidia-settings

and your Nvidia prime-select.

Check your display and also your Mouse Settings in case there are any conflicting settings.

You can test all your settings in one go:

mv ~/.config ~/.config-bk

Log out and back in or refresh the desktop or reboot - Test mouse on other monitor.

Aravisian, So I don't have the nvidia package installed. nvidia-settings was not installed. I ran prime-select nvidia. I archived the .config directory and rebooted. Same problem. Both displays work fine. When I first start up, or log into the system, the external will display the mouse with no problem. When I wake the display up, the internal display (the laptop screen) displays the mouse and whatever was on it. The external display, the AOC, will show whatever was left open, but not the mouse pointer. The mouse is registering. I can hover over toolbar items, or menu bar icons and they will register that the mouse is over them and they will register the mouse click. But there's just no pointer.

Are you using a custom Mouse Cursor Theme?

Which Nvidia driver are you using?

nvidia-smi

I haven't been getting on-line much due to work, so I apologize for not responding sooner. To answer your question, I'm using the default theme that was installed with Zorin 17.

Are you relying on the Intel Graphics?

I'm using the native graphics drivers installed with Zorin 17. So I'm not understanding your question.

You stated that you are using a Nvidia Graphics card with HDMI cable connected to it; but then said that you are not using the Nvidia (have no Nvidia package installed. This is confusing.
In Software & Updates > Additional Drivers, what driver are you listed as using.

Aravisian,
I apologize, I should have clarified that. I'm using the Nouveau drivers. I haven't installed any NVIDIA branded drivers or packages.

It may be worth trying the Nvidia supplied drivers to see if the mouse cursor issue is resolved by the drivers.

Aravisian,
This seems to have worked. I've been running the NVIDIA drivers for the past few days and haven't had any issues with it.
Thank you!

1 Like