No output from external speaker

So I installed Zorin on my dads Asus laptop and so far everything has been working great except when we try to plug the computer into a Yamaha speaker via audio out, no audio comes through. I went to sounds settings, and the only output options are "Headphones - Built in Audio" which is probably the speakers because it disappears when i unplug it and HDMI which is the projector. Neither of them output to the speaker.

Open Terminal and type
alsamixer

In alsamixer Hit F6 to confirm your sound card is correct.
then Hit F5 to show all sound channels. (It would be good if you then posted a screenshot of that display)

Then comes the fun bit (solving sound issues can be hit and miss)

If any output channels are showing [M] then unmute them by selecting and type "M", also increase the sound level slider.

If Auto-Mute is set "Enabled" try toggling that to "Disabled".

I am assuming your "audio out" is the 3.5mm headplone jack, or is it a combined 3.5mm headphone/mic jack?

1 Like

I disabled auto mute and unmuted and raised volume of the other speakers, wich only made more sound come out of the computers speakers, not the yamaha thing.

From your screenshot, you have not hit hit [F5] to show All sound channels, just showing playback.

Also try:
[Speaker] channel showing MM i.e. muted. Unmute it and increase level.
[Master] channel try increase the level on that one.
[Bass Speaker] showing MM i.e. muted. Unmute it and increase level.

If you see a [Loopback ] channel, you could try Enable that.

Sometimes alsamixer channel labling does not correspond with actual audio inputs/outputs, so it is worth experimenting.

Whatever i unmute, it always still comes from the computer speaker. There is no loopback channel

I played around with pulse audio volume control and it fixed it. I don't know what i did... but it works. thanks for the help!

That is often the case. It is often trial and error and no logic to the solution. Hope it keeps working over a reboot.

1 Like