No rotation/orientation lock button on quick settings panel

Hey everyone, new proud Linux user here. I was wondering, is there a way to configure the version of the GNOME native to Zorin OS 17 to display a rotation lock button in the quick settings menu. Sometimes I like to lay on my side with my 2-in-1 and I'd like if I could stay in landscape mode. If there's no method to achieve this (or at least not easily), can someone at least point me towards a command of some sort for disabling the auto-rotate feature. Thanks!
image
Screenshot from 2024-01-21 21-36-31

Try:

gsettings set org.gnome.settings-daemon.plugins.orientation active false

Then, to re-enable auto-rotate:

gsettings set org.gnome.settings-daemon.plugins.orientation active true

You can also download and install DConf Editor:
sudo apt install dconf-editor

Your setting would be under org / gnome / settings-daemon / plugins / orientation, entitled "active".

Be very careful with DConf Editor... you can really mess things up if you just go changing settings willy-nilly... research every change to determine the result.


You can set up hotkeys by going to Zorin menu > Settings > Keyboard Shortcuts, scroll all the way to the bottom, click the  +  button, then enter:

Name: Disable Auto-Rotate
Command: gnome-terminal -- /bin/sh -c 'gsettings set org.gnome.settings-daemon.plugins.orientation active false'
Shortcut: Super+D (you can use whatever key combination you want)

Now, when you click  Super + D , it'll disable auto-rotate.

Click the  +  button again, then enter:

Name: Enable Auto-Rotate
Command: gnome-terminal -- /bin/sh -c 'gsettings set org.gnome.settings-daemon.plugins.orientation active true'
Shortcut: Super+E (you can use whatever key combination you want)

Now, when you click  Super + E , it'll enable auto-rotate.


If the above dconf commands don't work, try:

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true
gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock false

It may also be found in your display settings under orientation.

I think I was able to find the schema, thanks to your advice

This dconf command works when the laptop is in tablet mode (360 hinge turned past 180):

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true

when I'm in laptop mode, though, the orientation lock doesn't apply which is a tad annoying, but ig I can live with it. Thank you so much! Problem Solved.