No sound and microphone on Zorin 16.2 -but card is detected

I have installed Zorin 16.2, switched from Mint distro. I like Zorin performance (have Lite version) and general appearance. The problem is that i can't make sound be heard from speakers. Microphone also not works. I am googling since last week and I think I tried all. Still no success. My case is different than other, as my sound device seems to be discovered by Zorin, but no sounds is played. Icon is active, inxi recognized Sound device

  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 

aplay also detects:

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: rt5645 [sof-bytcht rt5645], device 0: PCM (*) []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: rt5645 [sof-bytcht rt5645], device 1: PCM Deep Buffer (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

but alsamixer shows nothing:

This sound device does not have any controls. 

Of course i followed Zorin guide for sound fix, but it didn't help.
Computer is a tablet pc Lenovo Miix320.
Sound device name is Intel HDMI/DP LPE Audio

Any help wil be appreciate, thanks

Did you find this one from your websearch:

I found that using search the term "Intel HDMI/DP LPE Audio No sound Ubuntu 20.04"

Unfortunately, I couldn't try this, because when trying to run script described in that topic, i am getting

this script is only for debian, ubuntu, mint and elementary. You're using Zorin.

Apparently, only works with Fedora 33:

detected means it is recognised but does not work!

I created a probe of my laptop :slight_smile:

What makes me confused is that i switched from Mint, where sound was fine. On the list you provided Mint is also "recognized" ...

Gday @hepos ,
Sometimes it may take an update or two to have the new OS get what it need's.
Open pulseaudio, check in "Config" TAB, That the Profile is set to " Analogue Stereo Duplex"
In output/inputs do you see "Ports" are recognised & set to correct devices.
( These should be all set correctly by Default)
Try updating via software app.
& in settings, Click on " Additional Drivers" See if you have any available or select the appropriate one for your pc.
Restart after update,

Also open windows & run updates & let it reset itself with a new OS onboard. ( may help)

Still No Sound?
Try resetting audio follow the link,

Note: there are more than one fix in above link.

Hope this may help.

Hi @Ocka
Thank you for long and detailed answer.
On pulseaudio in config tab I have no profile "Analog stereo duplex" I tried to switch to each one in the list , no results

I installed latest updates, no additional drivers updates available.
Windows updates done, no success
Audio retested using provided link, all fixes tried.

What is interesting, what I haven't try before is that sound works on bluetooth headphones but on built in speakers and plugged in jack headphones not.

Is there any chance to try something more?

What options do you see in the dropdown menu for first Profile?
Have you tried turning that Profile on and see the effect of doing that?

@zabadabadoo yes i tried. It seems that this profile is for HDMI, which is currently not connected

words in brackets are disconnected / unavaliable

Ah OK. Worth a look, but no help.

True, bad news is that I am going to give up (slowly)

Ok, Thanks for the feedback,
Try this in the terminal,
sudo apt ubuntu-drivers-install
sudo apt update
sudo apt upgrade ( Note any errors )
restart pc.

Retry sound,

Note: in the config TAB, top profile " OFF" ( for hdmi connections)
2nd profile, as you have tried is good, but sometimes a change may not set until restart.

Also make sure you have any media player/app's turned off, while changing settings.
Check in " Startup Applications " that you, Have any app's that use audio/video, disabled.

see how that goes.

This maybe an installation issue ( corrupt file, usb drive, etc)

Thank you for keeping trying,
All steps done, except ubuntu-drivers-install
Execution of this command returns "Incorrect operation"

Unfortunately, still nothing. Any idea why I am getting this error?

I was able to make it run using sudo-ubuntu-drivers-install. But it says that no drivers found for installation.

Ok Next :smile:

Is this Dual boot or clean install ( Zorin only)?
If dual boot please open windows OS & let it run updates aswell.

Can you run this & show me the output please,
lsmod | grep intel

Next search Lenovo websites to check for motherboard & linux compatibility, also search for firmware/drivers ,
You could try:
sudo apt-get ubuntu-drivers autoinstall
sudo apt update
sudo apt upgrade
I think it may be better to re-install Zorin.
If you used balenaEtcher to compile the usb drive, Try Rufus.
re-download iso & run a checksum on the D/L. (download=D/L)
you may know all this but best to have it here just incase. Run your eyes over the link below.

This is to check the download integrity.

Note: MD5 check is done prior to install automatically.
If this is dual boot, disable fast boot & secure boot, prior to install.
If you can tell me any further info on how your setup works, eg: multi bootable partitions?
dual boot or clean?

Also try,
On your bootup GRUB, select " firmware test" If not on the bootup GRUB then,
You could insert/bootup from the usb drive & run the firmware check prior to install there,

Hi, this is an output:

intel_powerclamp       20480  0
intel_rapl_msr         20480  0
kvm_intel             376832  0
kvm                  1011712  1 kvm_intel
ghash_clmulni_intel    16384  0
aesni_intel           376832  11
crypto_simd            16384  1 aesni_intel
cryptd                 24576  4 crypto_simd,ghash_clmulni_intel
intel_cstate           20480  0
snd_sof_acpi_intel_byt    20480  2
snd_sof_intel_ipc      20480  1 snd_sof_acpi_intel_byt
snd_sof_acpi           20480  1 snd_sof_acpi_intel_byt
snd_sof_intel_atom     20480  1 snd_sof_acpi_intel_byt
snd_sof_xtensa_dsp     16384  1 snd_sof_acpi_intel_byt
snd_sof               139264  4 snd_sof_intel_atom,snd_sof_acpi,snd_sof_acpi_intel_byt,snd_sof_intel_ipc
btintel                40960  1 btusb
bluetooth             688128  41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
snd_intel_sst_acpi     20480  0
snd_soc_acpi_intel_match    61440  2 snd_sof_acpi_intel_byt,snd_intel_sst_acpi
snd_soc_acpi           16384  4 snd_sof_intel_atom,snd_soc_acpi_intel_match,snd_intel_sst_acpi,snd_soc_sst_cht_bsw_rt5645
snd_intel_sst_core     65536  1 snd_intel_sst_acpi
snd_soc_sst_atom_hifi2_platform   114688  1 snd_intel_sst_core
intel_xhci_usb_role_switch    16384  1
snd_intel_dspcfg       28672  2 snd_sof_acpi_intel_byt,snd_intel_sst_acpi
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
snd_pcm               135168  10 snd_sof,snd_sof_intel_ipc,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_soc_rt5645,snd_soc_sst_cht_bsw_rt5645,snd_pcm_dmaengine
intel_rapl_common      40960  2 intel_rapl_msr,processor_thermal_rapl
intel_soc_dts_iosf     20480  1 processor_thermal_device_pci_legacy
intel_int0002_vgpio    16384  1

I used Rufus to prepare USB with Zorin. I will try once again to install. Will get back here after this.

1 Like

Sorry my fault, wrong command,
sudo ubuntu-drivers autoinstall

I reinstalled Zorin from the scratch. Unfortunately sound didn't come. Well, i can play the sound on Windows: :relaxed:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.