No Sound "Dummy Output" AMD Family 17h HD Audio

I have dual boot with Windows 11 and Zorin OS-16.2.
There is no sound in Zorin, and the only ouput device under sound settings is "Dummy Output".

If I shut the computer down, boot into Windows 11 and then reboot into Zorin, then the sound works. If I reboot Zorin then it doesn't work again.

Here is the output of inxi -Fxz
Kernel: 5.15.0-58-generic x86_64 bits: 64 compiler: N/A
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.2 base: Ubuntu 20.04 LTS Focal
Type: Laptop System: HP product: HP Laptop 14-fq1xxx v: N/A
Mobo: HP model: 887C v: 59.17 serial: UEFI: AMI v: F.25
date: 07/05/2022
ID-1: BAT0 charge: 40.6 Wh condition: 40.7/40.7 Wh (100%)
model: HP Primary status: Unknown
Topology: 6-Core model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64
type: MT MCP arch: Zen rev: 1 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 50308
Speed: 1071 MHz min/max: 400/4056 MHz Core speeds (MHz): 1: 1277 2: 1122
3: 1076 4: 1041 5: 1153 6: 1264 7: 1098 8: 1263 9: 1149 10: 1098 11: 1179
12: 1098
Device-1: AMD vendor: Hewlett-Packard driver: amdgpu v: kernel
bus ID: 03:00.0
Display: x11 server: X.Org 1.20.13 driver: amdgpu
resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.0-58-generic LLVM 12.0.0)
v: 4.6 Mesa 21.2.6 direct render: Yes
Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus ID: 03:00.1
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: Hewlett-Packard driver: snd_rn_pci_acp3x v: kernel bus ID: 03:00.5
Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus ID: 03:00.6
Sound Server: ALSA v: k5.15.0-58-generic
Device-1: Realtek vendor: Hewlett-Packard driver: rtw89_pci v: kernel
port: f000 bus ID: 01:00.0
IF: wlo1 state: up mac:
Local Storage: total: 931.51 GiB used: 34.43 GiB (3.7%)
ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
size: 931.51 GiB
ID-1: / size: 686.51 GiB used: 34.40 GiB (5.0%) fs: ext4
dev: /dev/nvme0n1p4
System Temperatures: cpu: 54.0 C mobo: N/A gpu: amdgpu temp: 55 C
Fan Speeds (RPM): N/A
Processes: 322 Uptime: 28m Memory: 30.69 GiB used: 2.03 GiB (6.6%)
Init: systemd runlevel: 5 Compilers: gcc: 9.4.0 Shell: bash v: 5.0.17
inxi: 3.0.38

After shutting down, booting into windows, and then rebooting into Zorin, Here is the output of aplay -l -v

**** List of PLAYBACK Hardware Devices ****
card 0: Generic_1 [HD-Audio Generic], device 0: ALC236 Analog [ALC236 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here is the output once I reboot from Zorin back into Zorin and I type aplay -l -v

**** List of PLAYBACK Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

The sound no longer works after this reboot and the output devices under settings only show "Dummy Device" again.

I don't now if this will help you:

See if the fix with 18 votes solves your issue:

I did try pulseaudio -k && sudo alsa force-reload and it didn't seem to help. It briefly showed two "dummy output" options both of which didn't have sound. How would I go about trying a different kernel?

I also tried the option with 18 up votes. sudo apt purge timidity-daemon. It didn't work. Output was...

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'timidity-daemon' is not installed, so not removed
The following packages were automatically installed and are no longer required:
chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi heif-gdk-pixbuf
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Maybe see this re different kernels, but please do backup your files beforehand. [solved] WIFI on Asus USB-N10 adapter not working - #7 by Aravisian

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.